Internal sync setup error

I am unable to sync my newest computer, I get the “Internal sync setup error” message when I attempt it. I have tried the “Sync Internals/Disable” fix, nothing happens. No other error messages. All flags are default.

Computer is Windows 11 Home, V22H2. Brave v1.59.124

@PaleDriver Just to confirm, you’re saying that you’re able to pull up everything on Sync, enter your code, etc but then it doesn’t sync and you get the error? Or when are you seeing the internal sync setup error? Can you kind of walk along the process a bit of what you’re doing?

I like to be 100% confident rather than make assumptions, as sometimes I’ve been wrong in what I think is being said. Thanks!

That’s correct, I go through the steps, hit the OK button for “Are you sure” and get the message.

If it’s not too much trouble, could you try creating a new sync chain and see if it will connect?

Not sure what you mean. I can create a new sync code on the computer I’m trying to add, but in order to connect it to another device I will have to delete the original sync account, right?

Additional info: I just discovered that none of my Chrome based browsers (including Chrome) will accept passwords. I can’t import a file, nor will they remember any passwords that I type in.

That’s weird, @PaleDriver. I do know that for passwords and sync, it uses your device keychain in order to encrypt everything. If ever it changes or is unavailable, then it wouldn’t be able to access.

Based on what you’re saying, it seems like this issue is happening with you. I’m not sure if you’ve modified Windows or anything. And this goes beyond my realm of expertise overall. What I am going to do really quick is tag @Mattches in as he should be able to give you some better pointers on what to look at or try.

Just to make sure I’m understanding everything here — you’re saying that you’re unable to Sync your data from an existing Sync chain (that you already have on a device) to Brave on a new PC, right? Further, anything related to passwords in Chromium browsers does not appear to be working on your machine?

If the above is correct then it sure does sound like what @Saoiray is saying — but if the PC is new then I’m not sure why that would be the case. Do you have a password set to unlock the device?

1 Like

Problem solved! Not sure which step did it, but I uninstalled all my Chromium based browsers. When I got to Edge, of course, it couldn’t be uninstalled but only modified. So it was reinstalled and I signed in (maybe for the first time) and voila! All browsers are working!

Thanks for your efforts!

1 Like

Great work, glad to hear it’s working. Please let us know if the issue appears again.