"installer failed to start" error

windows
#1

Hello,
Im using win 7 32 bit. Ive repeatedly downloaded the installer. Ive run it while Brave 25.304 was running and it failed.
Ive run it when Brave was not running , it failed.
Ive run it with my firewall turned off and brave not running, and it failed.
Is there an OFF LINE INSTALLER & if so where because I cant find it.
((also this message insists on at least ONE TAG and when I tried to add my own it then stops me from choosing ANYTHING and wont let me post- ive tried 5 times and Im getting aggravated.
Thank you

1 Like

Brave update not working at all
#2

That’s because you’re posting in the wrong place.
You’re looking for Desktop Support. If you move your post there and follow the guidelines/template I’d be happy to help you.

0 Likes

#3

it clearly shows I posted in desktop support WINDOZE

0 Likes

#4

No, a Community mod, @eljuno, moved your post to the appropriate category.

You continue saying it failed - what happened when it fail? Did it just not launch? Did you get the right installer? Does the window show up as a blank screen? Was there an associated error message?

0 Likes

#5

downloaded the link and RAN. it says on your marks, connecting, downloading. then Upload screen shot . thats the error it says installer failed to start

0 Likes

#6

Hmmm
Do you have Kaspersky AV installed by chance??

0 Likes

#7

No I dont & I also tried it with my Anti virus turned off and this morning I tried it right from a cold boot.
I guess today I will search through my system and see if maybe my windows installer is blocked??? It certainly shouldnt be… but I will check.
AN OFF LINE INSTALLER would certainly solve the problem since I could disconnect from the net, turn off all A/V and firewalls and probably have a successful install. But Im NOT gonna do anything with no firewall and no A/v.

0 Likes

#8

Ditto on wanting the downloadable package without installing. As a network admin for our little church, it’d be super handy to be able to slap it on a USB drive and install on other machines when needed instead of dragging the network down with another download.

I tried looking, but couldn’t find anywhere on the Brave site to do so.

0 Likes

#9

I’ve got the same issue.
I run windows 7 32bit, and I run download pack in a user account (typing adm password)
May be Installer does not inherit administrative privileges?
Does the installer use folders in the user profile or use even other folders to install files?
@emailme123 do you use adm account?

0 Likes

#10

I had exactly the same issue as the OP earlier today. Also on 7 32 bit.

After trying a few different ways I launched IE11 browser (I am guessing most other browsers would work?), went to the brave site and downloaded the new browser. Launched it and imported my bookmarks and settings.

Does not really address the raised issue other then giving a work around that worked for me.

0 Likes

#11

Here you speak back to almost everything that has made sense so far. Did you deactivate the firewall and your AV program after disconnecting from the Internet? The installer needs an active Internet connection to work.
PS: As long as you don’t open foreign pages without a firewall and AV program, nothing should happen to you. To install Brave now, I think it would be safe to temporarily disable your security software (all).

Edit: I’m not using Windows 7, but it only seems to occur on this OS (Windows 10, just downloaded & installed with no problems). Do you have the latest updates installed on your PC?

0 Likes

#12

I ran it specifically AS ADMIN and it made no difference.

1 Like

#13

well I CAN understand that, just about every software on the market relies on PARTS of windoze or its favorite browser IE already being installed. Microsoft wont even let you do any updates unless you allow everything THEY want to be updated.

0 Likes

#14

Ahem S Of course I did NOT deactivate or cut off my internet CONNECTION while the Brave app was updating and download and installing its updates.
I fully realize the tiny download allows the computer to connect and download a larger install that takes time : D AS I said, an independent OFFLINE INSTALLER would solve this issue.

0 Likes

#15

For anyone who’s experiencing this issue I’ve forwarded it to the team to review. Hopefully we’ll find the cause soon and I’ll be sure to update this thread when we do.

1 Like

#16

Not sure why I fixnt think about this earlier, but we actually have offline installers available now. They’re marked as “Standalone” on our GitHub:

(sorry for the weird image, on mobile atm)

2 Likes

New install doesnt work normal
Cannot reinstall Brave
#17

THANK you very much Mattches, however because of others having big problems too Im going to wait a few weeks before I try the off line full installer. but TY !
I just dont need any software headaches right now S
Merry ho ho.

1 Like

#18

Hi I’m having exactly the same problem on Win 8.1 Pro 32-bit (all updates installed)

0 Likes

#19

Have you also read the previous posts? Here is the solution, if applicable:

0 Likes

#20

Thanks yes I read the previous posts and saw that “workaround”. I just wanted to highlight that it’s also a problem with Win8.1. I’m not in urgent need of the update so will just try again in a while to see if it’s fixed.

Thanks
Marc

0 Likes