Incapsula web security is blocking Brave browser

Two sites have recently started blocking me, and both sites have security by Incapsula. These are and Their customer service cannot tell me why and to use Edge, which I detest for its insecurity… Why is Brave being blocked?

Hello @Ixthusdan, thank you for reaching us out. What kind of device and OS are you using? Have you tried turning OFF/ON your shields and make sure that Secure DNS is ON, Upgrade connections to HTTPS is ON and the one that says block scripts is OFF.

On the other hand, they might not be blocked by Brave, likely from an anti-virus program. Check your anti-virus program or turning OFF firewall. They might have taken over your browser certificates too. Let us know if that works. Regards.

I’ve seen some of these error messages before;

Either I was visiting from a non supported country, or it detected I was using a VPN.

Thank you for responding. The issue is a conflict between Brave and Incapsula. From the same location, without changing anything on the computer, Edge connects fine. As I have said, I can browse with secure connections to other sites, but not a site using Incapsula. Brave was fine until mid December. Incapsula has changed what they are doing. I was hoping that a setting in the browser could imitate Edge, like Chrome used to have.

Can you show us a screenshot of what the error or ‘block’ looks like?

And if you could tell us the exact URL that may help as well (feel free to redact anything sensitive).

Caremark accepted my sign-in today, but CVS still blocked. I went into my settings and deleted CVS cookies, and now all is working.
I had Google Tag Manager and Google Optimize running as extensions. I turned them off. So now both sites are allowing me in. I was originally getting the error 15 block from both. It works now; hard to believe that those extensions may have caused an issue. I use Avast Free for antivirus and never turned off the shields. I would think Edge would have been blocked had it been Avast.

Does load?
What shields settings is enabled?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.