Access Denied, You Don’t Have Permission To Access on This Server

It is happening more and more that I am getting Access Denied, You Don’t Have Permission To Access on This Server for Brave. I like Brave but it is not working so well lately. Are companies black listing Brave due to its’ shields and privacy protections? I have to start using another browser now and really don’t want to. I use a VPN with Brave. I don’t get the same message with Google’s Browser using my VPN.

If the servers are unwilling to work for the browser, they’re probably data criminals who hate that they can’t get your information.

Nah. In fact, if you’re seeing things like this, you should be reporting the sites so it can be looked into and resolved. Heck, even to see if others can replicate it or if it’s something just solely on your end.

Do you work for Brave or are you a user? Many banks are not even taking Brave. Home Depot also doesn’t work well on Brave. Can view “more details” for products when on Brave. There are a more and more websites that won’t work or work well with Brave. Maybe Google and the Mainstream Browsers are getting together to stop Brave because they can’t spy on us?

1 Like

Many Banks and even Home Depot (can’t see “more details” on products) don’t work or don’t work well on Brave.

No, I am just a user like yourself. Brave has been great for blocking ads. In general, I do not use the internet for banking or other things.

Not true

How so? I have absolutely no issue. I just went to Home Depot and was able to create an account, log in, browse, log out, browse, etc. There was no issue.

Again, works for me.

What I will say has happened with banks is because of hackers and all, they do require IP address. If you don’t provide IP, they can prevent you from logging in. This is to try to help prevent issues if someone else accesses your account to steal your money. They want to be able to try to track the people taking your money.

It could be your Shield settings on top of your VPN could be blocking the relevant information they specifically need. This wouldn’t be targeting or blacklisting Brave as you mentioned but instead just would be targeting everyone, where you agree to share certain information if you want to use their services.

Extensions also can break websites or have issues. So if you have extensions running, any of them might be causing you problems. If you need help, then probably need to have you check things like Shield settings, trying to access in Guest Window, finding out which OS you’re using, which version of Brave, and some other info to try to help troubleshoot issues.

Thank you so much. I am happy to hear that Brave is not being Blacklisted. I will check the Shields and VPN that I use. It is understandable that Banks need to have safety protocall to limit fraud.

I can sign in to Home Depot and browse items but if I want product detail it blocks me from seeing the product detail. It gives me that I don’t have authorization. If you can access product details, It must be my VPN or Shields. Thank you for your response … much appreciated!

I have been using Brave for a couple of years now and have recommended it to others. I really like Brave and think it is the best browser for safety and to stop tracking. I just recently started have issues. Perhaps I changed a setting. Another person said as far as bank sign in’s, it is my VPN. Have a wonderful day and thanks for your response.

I guess we’re just having to figure out why. As you saw in my video, I was able to do that with no issues. If you can grab screenshots or anything, it might help. It’s difficult knowing where to start on troubleshooting.

That said, if each of you would like to try some basic troubleshooting steps, we can make our way through to kind of check if anything else might be causing issues. Try each step independently. If it doesn’t fix the problem, then put settings back to normal (or go to your default profile) and then try the next step.

1. Turn off Shields.
This will just kind of help to figure out if Shields settings might be causing an issue.

2. Open in a Private Window and try
The purpose of this is to see if extensions might be causing a conflict. Unless you’re changed settings to allow extensions to run in Private Window, this would run Brave without extensions. If it works here, then you know extension is likely what’s breaking things.

3. Try in Guest Window or Create a new profile (this is available Desktop only. Guest Window is temporary until window is closed, New Profile exists until deleted. Otherwise do the same thing)
This also is done to check extensions, but it goes one step further. Overall your browser goes back to default settings in the New Profile or Guest Window. So if it doesn’t work with Private Window but it works here, then likely is a setting you changed. The challenge, of course, is figuring out which.

4. Clear site settings
This is kind of a long shot. If this was the issue, should have seen resolved in new profile/guest window. However, sometimes it’s a random cookie or a toggle on Shields you may have persisted when it shouldn’t have. So clearing helps put all site settings back to default and can work. Easy way to access Site Settings if you’re unaware is to click on the lock icon in your address bar and then go to Site Settings from which you can Clear Data.

You can also go the more annoying route of brave://settings/privacyClear browsing data, choose All Time, and then make sure it’s clearing Cookies and other site data. This will log you out of everything. It’s more thorough but meh.

NOTE

You never did provide information which might be helpful too.

  • Which version of Brave are you using?

  • Which OS and OS version? (such as Windows 11, Android 12, etc)

  • Also should have put in troubleshooting steps, but are you saying it works with VPN off and only an issue with VPN on?

I will give this a try tomorrow and let you know. I think I set Brave to be too strick. Brave is up to date
Version 1.46.144 Chromium: 108.0.5359.128 (Official Build) (64-bit), I am using Windows 10. I always have VPN on … if it goes down, the kill switch cuts me off the internet. Google works with my VPN, so I think it is a Brave setting. I don’t use extensions. All the sites work OK on Google but I much prefer Brave.
I appreciate these steps and will let you know as soon as I figure it out. Thanks so much!!

I forgot to send you this from Home Depot. I want to view detail for a product and this is what I got:

Access Denied

You don’t have permission to access “http://www.homedepot.com/p/ZLINE-Kitchen-and-Bath-60-in-Autograph-Edition-4-Door-French-Door-Refrigerator-with-Internal-Water-and-Ice-Dispenser-in-Stainless-Steel-RBIVZ-304-60-G/323938871” on this server.
Reference #18.2b422417.1672983210.95aa3e59

@Dance I just tried researching a bit. According to a post online, I see others had this issue and they were saying:

This is a geolocation protocol.

I cannot access any of their us-based subdomains from the UK.

If i switch my VPN to Miami or anywhere in america the site becomes accessible immediately.

Weird way of keeping non-us residents away from a particular site but hey, it’s their subdomain i guess :woman_shrugging:

Actually a few people saying that at https://answers.microsoft.com/en-us/microsoftedge/forum/all/access-denied-you-dont-have-permission-to-access/55930c1c-b87a-4a22-b00f-3f71c4dbae37

Also talked about back in 2020 at https://news.ycombinator.com/item?id=25356199

So yeah, seems like it’s probably due to whatever VPN node you’re using. Which country are you located? Are you using VPN for same country or different?

My VPN shows in the USA. Can you tell me what settings should Brave be on in the DNS and IPSF settings? I had them OFF

I Don’t have this DNS button “ON”. Is yours turned on? “Automatically redirect to IPFS pages via DNSLink when possible Automatically uses DNSLink to navigate to an IPFS version of a website when possible”

I HAVE THIS SETTING ON FOR DNS (SEE BELOW)
Use secure DNS
Determines how to connect to websites over a secure connection
With your current service provider
Secure DNS may not be available all the time