Ideal betaling werkt niet

I recently had a problem with Ideal payments. iDEAL is an e-commerce payment system used in the Netherlands, based on online banking. Introduced in 2005, this payment method allows customers to buy on the Internet using direct online transfers from their bank account. At the bank I arrive at a non-existent page instead of the payment page. If I log in with a different browser on the same PC I can pay, but not with Brave. I have read in an answer from the bank that they do not support Brave, but until last month it worked and even if I only work with Brave via another browser, it no longer works. How can I fix that?

Cache, cookies & browser history deletion didn’t help to fix this error:

I have the same problem. Which is frustrating because now I have to use another browser for iDeal payments. I’m now thinking about switching to another browser all together.

I have also the exact same problem. This is very annoying.
Refreshing the page didn’t work.
However I found out a bypass if this error page appears.
When the error page appears go to the padlock in the address bar and click on site settings.
image

Change one of the permissions to allow and change it back to what it was before.
If you go back to the tab with the error page there should be a now above the page an option to reload the page with the updated settings.

The page should now load the payment page.
The strange thing is that none of the settings were changed for the page.
However this method seems to work for me but it is still annoying and I hope Brave can fix this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.