I need help installing chrome extensions on Brave


#1

So, I was trying to install chrome extensions through these instructions here :

But I really don’t know what to do, the instructions are too hasty and ambiguous for me to understand them at all.

So, after installing this https://git-scm.com/downloads and this https://nodejs.org/en/

I made a path in C:\Program Files\Git> and ran the git-cmd application on the same path

Then, I ran the command cd browser-laptop-master to get inside the folder.

After that, I ran the command npm install.

And then, I got those error messages below -

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: electron-installer-debian@github:brave/electron-installer-debian (node_modules\electron-installer-debian):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for electron-installer-debian@0.5.2: wanted {“os”:“darwin,linux”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: electron-installer-redhat@github:brave/electron-installer-redhat (node_modules\electron-installer-redhat):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for electron-installer-redhat@0.5.0: wanted {“os”:“darwin,linux”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin-linux@^1.1.0 (node_modules\7zip-bin\node_modules\7zip-bin-linux):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for 7zip-bin-linux@1.1.0: wanted {“os”:“linux”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin-mac@^1.0.1 (node_modules\7zip-bin\node_modules\7zip-bin-mac):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for 7zip-bin-mac@1.0.1: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm WARN eslint-plugin-react@6.9.0 requires a peer of eslint@^2.0.0 || ^3.0.0 but none was installed.
npm ERR! Windows_NT 10.0.14393
npm ERR! argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” "install"
npm ERR! node v6.11.4
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! ad-block@3.0.5 preinstall: npm install bloom-filter-cpp && npm install hashset-cpp
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the ad-block@3.0.5 preinstall script ‘npm install bloom-filter-cpp && npm install hashset-cpp’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the ad-block package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm install bloom-filter-cpp && npm install hashset-cpp
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs ad-block
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls ad-block
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Program Files\Git\browser-laptop-master\npm-debug.log

Can somebody help me, please? I need clear instructions and the source link isn’t clear on how to proceed.


#2

I had the same problem, while trying to follow instructions on this page:


#3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.