I just noticed 4.75 usd when my wallet disconnected

So sometimes if i leave my browser open for a long period of time and today i noticed it was disconnected once again and their is 4.75 in coin how can i get it to my gemini wallet with my other tokens

@Chasertheraser Just click the Connect button in the top left corner of you rewards panel and follow the prompts. If you have any problems, please post an update. I am also linking a Brave Help Center article that may help. Please note is is a little outdated (says “Unverified” vs “Connect” but the actions should be similar. The appropriate section is titled : How to verify your Brave Rewards profile. Once you are connected, any outstanding payouts will be deposited into your Gemini account. Hope this helps. Take care.

That is actually a bug. If you go to brave://rewards-internals
it will most likely show profile not created which not the case. That happens on my android too, generally restarting Brave or the device helps. For me restarting Brave works perfectly fine.
@Chocoholic another thing you might wanna notice which must’ve slipped when you went away for a while!


I will share a screenrecord by me. Don’t mind the music, I seriously forgot to turn it off. The don’t let me go is for my vBAT lol

@chriscat @SaltyBanana I remember bringing this upto you both in DM, but never got a solution / follow up on this.

The steps to reproduce this could be to keep brave in android background apps for 20 mins minimum, sometimes even longer. Then just go back to Brave and you can notice that connected will show disconnected and rewards profile isn’t created.

I have it usually connected when i connect the amount is different i want those funds added to my connected gemini wallet that will reconnect once i open the browser

Yes that what happens, so when is disconnects there is a balanxlce sitting there of 4.75
But my connected balance is like .50cents

If that Balance is not getting transferred, then best way to get support would be to raise a ticket at

@SmartyAadi Thank-you for the heads-up! Hopefully I will “catch-up” soon. Thank-you for having my back and letting me know. Appreciated. :slightly_smiling_face:

1 Like

Yeah, I’ve had this on android for some time now too.

@Chasertheraser @Thrive Just to confirm, restarting first Brave and then your device does not work. Is this correct?

Please post an update. I want to ensure I am following thread correctly and not making assumptions. Thank-you! :slight_smile:

I don’t want to hijack OP’s thread, but if we do have the same issue it seems (to me at least) more manageable for mods and helpful to the community to focus discussions on the same topic in one thread, rather than flood the forums with separate ones. An easier way for us all to support each other, exchange info/solutions/suggestions all in one place… share the love! :smiling_face_with_three_hearts:

In my case it was easily reproduced by opening Brave; and fixed by closing and restarting the browser. But it would happen over and over again… every day! Clicking the triangle showed Uphold disconnected, eternal wheel under Your Balance/Estimated Earnings (so unlike the OP I didn’t see a balance when wallet disconnected) and then this year the browser also started repeatedly freezing and crashing - restart/wait. Internals info showed no wallet connected, no country, no anything! Close, restart, fixed. Originally reported around April/May of last year, discussed again here.

You might notice I am using the past tense. Only I just tried to reproduce this (usually simple) and for the first time in months it seems to be working properly :hugs: and I can’t reproduce! Hoping :pray: the latest update has fixed it because up until a few days ago it was definitely still broken! :laughing:

1 Like

Oh that is great. Hopefully it will not revert back. Oops, hope I didn’t just jinx the fix! lol

I read the release notes and didn’t see anything about this mentioned. May have overlooked it or it was a fix excluded from release notes.

Thanks for the link to the previous topic on this issue. Helped. :slightly_smiling_face:

1 Like

Well, I had raised with @chriscat a long while ago. He said they weren’t able to reproduce the issue so probably they aren’t able to fix it!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.