Cant verify on gemini even though gemini says im connected

Well i finally disconnected from uphold. Now I’m trying to connect ro gemini and relize I was already connected to it. I disconnected becasue it was saying im unverified and tried cinnecting again. Got the “try again later” something wrong message after clicking connect. Well I went on Gemini to see my connected accounts and it says im connected to Brave just fine. Here is the screenshot below. I have 50 BAT im trying to withdraw…

Also im in united states…

Ah, this is the tougher one to mess with. Sometimes this happens when it’s just a communication issue between Brave Gemini. Other times it happens because the person’s account has been flagged but it’s not yet wanting to report it. Then there’s the “nobody knows why” situation, but it eventually resolves. I have no idea where yours falls in or if there’s a category I failed to mention.

Your best bet will be to submit a support ticket in case it is the flagged situation or something where Brave can help directly. Beyond that, only thing I can think of is to occasionally try again.

All of that said, can you also make sure you’re using the most recent version of Brave?

1 Like

Yes i am using the current version. Dang im so lucky i always get the rarest error for everything. Lol

Lmao, yeah. I mean, it’s kind of been an issue as of late, but like I said, it’s like one of the “three” reasons. In two of the circumstances it takes Brave doing some magic on their end. If you want to see fairly recent examples, check out posts/topics below:

I mean, can also say things like clear cookies/cache, which supposedly worked for a person or two. But I’m not sure if that would really do it. I’ve been trying to keep an eye out for any similarities or solutions, but majority seems to have to rely on Brave, with even one person before who went months without a solution while constantly providing information to Brave. It definitely can be a headache. Hopefully yours won’t be that tricky and it’ll be resolved within a few weeks like it was for many on that first post/topic I linked to here…assuming you get a support ticket going.

1 Like

@Evan123 mind taking a look at @Native702’s issue?

1 Like

@Native702 Could you DM your Wallet Payment ID found here: brave://rewards-internals/

Thanks!

1 Like

Sorry yes hold on and by the way i messaged gemini and they sent me a link to connect and whe. I clicked it apere tly i was still connected to uphold. Well i disconnected uphold becasue that account was closed and tried to connect to gemini again. Same thing happened it failed, but it did show a different screen this time. Also it deleted my 50 BATs. I went to internals and tried to fix it. It fixed kinda when i clicked on wallet, but it sometimes goes back to zero when i click the rewards icon on top right. Here is my address

It says brave rewards not reated yet. No custodial account connected. But i have an account it has 40 BAT in it

I mean 50 BAT rewards in my account and this sucks.