I can't switch Back to Horizontal Tabs stuck in Verticle tabs

Greetings, everyone! Today, I opened Brave and installed the latest updates. I decided to give the vertical tabs feature a try and see how it looks. However, when I attempted to switch back to horizontal tabs, Brave started crashing repeatedly. I tried right-clicking on the tab and deselecting vertical tabs, but it still crashed. I even went into the brave://settings/appearance and tried to turn off vertical tabs, but it crashed again. Additionally, I’m unable to scroll in the vertical tabs. I have multiple tabs open, and every time I try to switch back to horizontal tabs, Brave crashes once more. I had to restore the window, and when I did, I couldn’t see any tabs. It seems there are numerous bugs, and I need assistance to switch back to my preferred horizontal tabs. Thank you for your help!




Imgur
Imgur
Imgur
Imgur

If that’s the case, then it sucks, seems like Nightly is still a better experience to run Vertical Tabs for not being 300 years behind updates like Stable is.

Anyway, you should test disabling the flag brave://flags/#brave-vertical-tabs

If not your only option would be to edit the Preferences file, you close Brave, go to User Data and your profile (default or profile1, 2 3 and so on) and then find "vertical_tabs_enabled": and set it to false save and done.

Thanks a lot, man it worked I got my Horizontal Tabs back :people_hugging:

PSA for anyone with this problem who is using Brave on a Mac:

To edit the preferences file, it seems that you have to edit the default profile (I have 4 profiles, and mine didn’t have the vertical_tabs_enabled flag in them). Only the preferences file in the default profile did. The file you need to edit is:

/Users/[yourusername]/Library/Application Support/BraveSoftware/Brave-Browser/Default/Preferences

In that file, search for the flag and set it to false, as anon57438784 suggested. Worked for me. Just thought I’d save you some time hunting for the flag in the right file.

Brave Version 1.61.100 Chromium: 120.0.6099.62 (Official Build) (x86_64)