Brave Crashes when trying to disable vertical tabs

Description of the issue:
On Windows 11, disabling vertical tabs crashes the Browser.

How can this issue be reproduced?

  1. Start Browser, right-click on a tab, enable vertical tabs. → Tabs are shown on the left side.
  2. right-click on a tab (in the vertical tabs list), disable vertical tabs → Brave window closes (crashes)
    2a. Open settings, in tab settings, disable vertical tabs → Brave window closes (crashes)

Expected result:
Brave should not crash and vertical tabs should be disabled and switched back to horizontal tabs

Brave Version (check About Brave):

Additional Information:
Crash reports:

I can attempt to reproduce on a Win11 system later.

In the meantime, is anything set in brave://flags ? (Anything with a non-default setting will be sorted to the top, and will have a blue dot next to it.)

1 Like

Ah, good point. Yes, brave://flags/#scrollable-tabstrip is set to scroll and shrink to medium width.
I’ve set it back to default and now Brave doesn’t crash when I switch back to horizontal tabs.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.