I am unable to allow notification for all sites or a site

I am unable to allow notification for all sites or a site.
I would like to allow notification for https://voice.google.com/.
My Brave is up to date: Version 1.39.111 Chromium: 102.0.5005.61 (Official Build) (x86_64) on macOS Mojave 10.14.6
I have tried all the following 4 methods:

Under “Settings” - “Privacy and security” - “Sites and Shields Settings”- “Notifications”,
I am stuck at “Don’t allow sites to send notifications” and am unable to select any of the other 2 greyed-out click button options: “Sites can ask to send notifications” and “Use quieter messaging”.

I added the URL on “Customized behaviors” - “Allowed to send notifications” to no avail.

When I click on the added URL, I could not drop down the greyed-out selection menu on Notifications with a grey message: Notifications Blocked by an extension. I disable all extensions to no avail.

The site I wanted to allow notification is “https://voice.google.com/”.
At the site, when I click on the “lock icon” in the address bar, the “slide-on” option is shown as a piece of a “jigsaw puzzle” for the option of Notifications with a grey message: “Not Allowed (Default)”.

Allow notification

Hi

@johnnybegoode

Disable extensions and try to enable notifications.; Maybe an extension is the culprit.

Thank you! I discovered that It is with one of my extension.