A way to activate/get notifications - Brave for Mac

Description of the issue:
I’m trying to be a Brave Journalist and switch from Chrome to Brave Browser completely. In Chrome whenever I visited a news site, I got the invitation to show notifications on updates from that site in my Mac’s notification system. If I wanted to see notifications from that site, I just clicked ‘Allow’ and Robert’s Your Mother’s Brother (Bob’s your uncle!). If not, I just clicked ‘Block’.

However, after I switched to Brave, only a couple of sites have offered notifications, so I’m thinking maybe there is a function that is blocking the notifications function on news sites that I’m visiting?

I’m hoping to make Brave my new Browser Bungalow on the Internet because this browser is SUPERBLY fast and takes a great load off when doing research. However I greatly rely upon getting notifications from news sites. Any help with how I can get notifications from all sites that I subscribed to in Chrome, would be enormously appreciated!

OS: MacOS Mojave 10.14.1
Brave: Version 0.65.121 Chromium: 75.0.3770.100 (Official Build) (64-bit)

Love this – will be stealing the phrase for personal use with your permission :slight_smile:

As for your issue, can you provide a couple example sites in which you should be prompted to receive notifications from that you don’t?

Brave’s default setting is to Ask for permission before sending notifications. If you’re not being asked, there may be an underlying issue at play here. However, you can also enter site exceptions (to Allow or Block) for notifications manually by navigating to Menu --> Settings --> Additional --> Privacy/Security --> Site Settings --> Notifications and entering the site URL(s) in the appropriate section.

Note that entries here must be of the form https://[website].com:443 as shown below:
image

1 Like

Welcome, @B.R.A.V.E. This might be non-helpful, but you might check that your Brave hasn’t somehow been set to Block by default in that same location. Mine is as shown below (I get far too many as it is). If I click the toggle, it goes to the Ask setting @Mattches mentions:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.