I am getting errors for most pages, including Brave (Mac)

Out of nowhere, I am getting “invalid certificate” errors, even for Brave pages. No computer settings were changed.

The pages work fine with Firefox.


1 Like

Can you please tell me what macOS version and Brave version you’re using? Additionally:

  • If you visit a website in a Private window, do you get the same results?
  • Do you get the same results if you disable any active extensions?
  • Have you tried clearing your browser data/cache?
  • Do you get the results if you create and visit a site in a fresh profile?

Emptying the cache, turning off extensions and using a private window all have no effect. Not does restarting!

Version 1.30.86 Chromium: 94.0.4606.61 (Official Build) (x86_64)

OSX El Capitan (No, I do not want to update).

1 Like

Did you test with a new profile?

I am not logged in with a profile.

It happens on two computers!

I am still having this problem on both computers today, and I do not understand why Brave has not fixed it (unless it is a Chrome problem).

I really hate changing browsers, but I can not find a solution, and it is definitely not on my end! Just suddenly appeared after installing a new version!

Me too! and I’m using El Capitan also. The only way I could post this was to use Firefox because I could not acces brave.com or even support.brave.com. I had to open an account for the Brave Community using Firefox and then pasting the code from the email into the address bar in Firefox so that I can write this right now using the Firefox browser.
Like the poster above, the constant Privacy Error messages began two days ago. I have been able to get CNN to open regularly and Wikipedia, but most of the sites which I have been visiting for years arenow walled off by this “security” element protecting me, including apple.com !!

Version 1.30.87 Chromium: 94.0.4606.71 (Official Build) (x86_64) – macOS 10.11.6

Matt, I tried almost all of the suggestions that you made and others, which I cannot remember at the present moment. Right now I am going to use Firefox until things chang with Brave.

Let’sEncrypt has a solution for Macs:

Download Let'sEncrypt ISRGRootX1 certificate:

Install the certificate by running the file, the KeychainApp opens it by default. Pick "login" for the one user or "system" for all the users on the machine to be affected by solution.

A window with a list of certificate opens, find "ISRG Root X1" and double click on it. Click on TRUST and change to ALWAYS TRUST.

Quit everything. Restarted the Mac and Chrome is now working for me like nothing happen.

To confirm, these steps did work for you? If so, @LeNoir can you please test and see if they work for you as well?

Yes, on two computers.

1 Like


I followed your instructions. Downloaded the .der file, opened it and clicked on Always Trust, then restarted. When I reopened Brave, at first everything worked swell. I visited about 15 random sites and each opened as usual. Then all of a sudden, I began receiving the Privacy Error screen. After this, the error screen appeared most frequently. I saved URLs for three different kinds of sites where the error appeared preventing me from accessing the site. (By the way, I always connect to the internet using VPN Secure service.) (Firefox still works without a hitch.)





Those instructions were from someone else. Yes, I have not have had those problems with other sites, but I do have them with these sites.

However, the error message is different, and I do not know how to solve this one!

I’m getting the same results as @Salsa here when I try to visit the sites you linked above. I think that that is a site issue rather than a Brave issue – are you seeing the error on other sites as well?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.