Can only open brave when running with sudo (mac command line) | Cannot access any sites "NET::ERR_CERT_INVALID"

Description of the issue:

  • Sometime last year (before Catalina came out, I’ve since updated but still occurs) Brave simply stopped opening (after clicking brave icon it just bounces a few times then nothing). I read the support pages and only a couple of other people had the issue but none of the resolutions worked for me. I experienced many glitches with Brave then and figured I’d wait till the software was ready for use. One day after playing around with it I figured I’d try running with sudo “sudo “/Applications/Brave Browser.app/Contents/MacOS/Brave Browser”” and it worked.

I was able to use Brave again (if it closed I would have to open again with command line) for a while until now all of a sudden I can’t access any sites. Every site I access gives the "your connection is not private error. I’ve attached a screenshot of the cert not valid error while the cert itself shows as valid.

How can this issue be reproduced?

  1. try to open brave by double-clicking the Icon
  2. Attempt to visit a site by typing url or searching.

Expected result:
I would expect to double-click the Brave Icon in the app tray to open Brave and after typing google.com for it to take me to Google

Brave Version( check About Brave):
[Version 1.11.97 Chromium: 84.0.4147.89 (Official Build) (64-bit)]
Additional Information:
Normally when I install software on my Mac, I either have to click “open anyway” on a security pop-up window on first run or sometimes it makes me go into security settings to press that button. I’ve already hit “open anyway” each time I’ve attempted reinstalls

I’ve tried reinstalling before I updated it to Catalina and after.
I’ve tried uninstalling and manually finding and removing related files.
I’ve tried uninstalling it using AppCleaner, which removes all related files.
I’ve tried beta and nightly versions.
I’ve tried opening websites in incognito mode.

Still unable to use Brave on my MacBook. Is this the best channel for support?

@Mattches need support here.

2 Likes

@Kirpy0x,
Thank you for the thorough report and for your efforts in testing. I’ve reached out to the team for more info because I’m not entirely sure what is going on here – especially after the Nightly/Beta versions producing the same results.

Appreciate your patience and I hope to have more information for you asap.

1 Like

Keeping this fresh.
Just updated to Version 1.13.82 Chromium: 85.0.4183.83 (Official Build) (64-bit) Still no luck on both issues.

Also had update to Catalina 10.15.6 still no luck

@Kirpy0x,
Are you connected to a VPN connection and/or do you have any anti-virus software installed on your machine at this time? I’m wondering if there is a MIM cert. from an AV product causing the behavior.

No VPN or antivirus software.