Invalid certificates for very reputable pages please advise

I hope one of you can help me every boot web page I am going to whether it’s google.com or brave.com comes back with an invalid web certificate that’s set to expire any day which is unusual for Google or any reputable site. But every single web address I type in automatically routes to some crazy PHP I believe source code and it’s always invalid. In addition to this none of my accounts will sync I’ve yet to be able to verify my brave account even though my uphold account is solid and it’s verified everything’s just disabled. I’m not a programmer I am very much in need of help.

That sounds very odd, and I’d say it’s not a Brave problem by the face of it.

Can you provide a little bit more information so that people can help you?

Like, have you tried accessing those websites with another browser from the same machine and network? What do you mean with “boot web page” exactly?

Can you quote the exact invalid web certificate messages, and the “crazy PHP” thing – I guess you are shown some PHP source code instead of the page you are expecting?
The thing is, if really “every single web address” you type returns some PHP, that must come from somewhere and since not every web site uses PHP and, as far as I know, neither does Brave, I’d say it has to be something “along the way”, between the Brave browser on your machine and the destination website server.

My wild guess is that it’s something to do with your ISP or some proxy on your network, or maybe the VPN if you are using one, can you provide some details about your connection (like, Country, ISP, is it at home or a workplace network, is it some wired DSL or wireless access point, …)?

By the way, also make sure the clock on your machine is correct.
Since quite a while, connections from a machine with the clock off by more than a little bit (not sure how much) are refused, IIRC to mitigate some security risk with “replay attacks” (that’s when captured traffic is played back to impersonate another user) but do not worry if I did not explain myself very well or it sounds alien to you, just check the clock.

You may also look at Configure user agent - #3 by caldercay and try setting the “user agent” to that of Chrome or Firefox. Remember to set it back to automatic when done.

I also advise to report which device (tablet? pc?) and operating system you are using, and the Brave version.