How to keep Brave in the background even with the screen off on huawei android

I’m using brave on Huawei P40 Pro, and because Huawei can’t support Google services, I’m using Google duo website (as desktop site) on Brave and it works, however, whenever my screen turns off or locks, it stops my communication and when i unlock the screen, the call shows that it is connected (i believe it’s already disconnected at this point) and then a few seconds later it drops the call. How I can make that work in the background? I checked all the possible settings on huawei P40 pro and it lets brave work in the background. I’m not sure why this happens.
How I can make it work, so I can still speak even with the screen off?

Thank you

You can try turning on ‘Background Playback’ in Brave settings.
Worked for me

Hey, thank you for your reply. Turned that on and I also chose to “allow” the brave app - How to stop your HUAWEI device from closing apps automatically. it seems to work with screen off too when I have YouTube open. I will let you know regarding the calls. Have you tried it with video call/voice calls?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.