How to disable tab auto-refresh?

I usually work with multiple tabs open. Whenever I go back to some of these tabs Brave automatically refreshes them. This is stressing me mentally, wasting my time, and affecting my productivity.

Please how do I stop my Brave Browser from auto-refreshing my tabs?


Hi @CryptoSorted,
How many tabs do you have open?
Do you use any tab manager extensions?

1 Like

Between 6 to 10 tabs in most cases.

No tab manager extensions.

1 Like

how much RAM does your computer have?

1 Like

Can you try creating a new test profile and seeing if the issue persists?
Click on the menu icon in the top right corner > create a new profile.

1 Like

While using Brave to check if you have enough ram, just open windows task manager and watch the performance tab, specifically memory. 8GB of RAM should really be the minimum. If your system is lacking memory, you can increase the default minimum size of window’s pagefile and that could help, add/replace RAM, or limit memory hungry applications and tabs.

Once logged in with CryptoWallets it uses a sizable amount of RAM, you can disable it from starting until needed. I end up killing tabs that are greedy and just reload them when needed. The browser’s task manager is very helpful to find bad websites that use too much memory.

1 Like


Are you serious?

I see. I will try this and see how it works. Thanks

yeah, really serious :expressionless:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.