How to access webapps in Ubuntu?

Description of the issue:

I installed Youtube and various other webpages as web-apps using the hamburger menu and selecting install youtube and then it opened as a window. But after closing that window I could not find the Youtube icon anywhere to launch the web app I had created.

I also installed many web apps by
Hamburger-menu > more tools > create shortcut (open as window)
But the shortcut does not get created anywhere.

Brave Version(
Version 1.28.105 Chromium: 92.0.4515.131 (Official Build) (64-bit)

Additional Information:

I am running Ubuntu 21.04

Thank you for reaching out to us. So to confirm, you do see the shortcut appear initially after creating it, but after using the shortcut once, it will be gone after you close the resulting window – is that correct?

If so, while the window is open, do you still see the shortcut where you saved it?

I use Windows, so I might be totally wrong here.

But, do you have a search option somewhere, where you can search for apps/ settings?
If yes, search for “YouTube” and you will see it. Then create a shortcut for it.

What? No. No shortcut is made.

When you tell Brave to “Create a Shortcut” it just opens the site as a web-app without creating a shortcut anywhere.

If you go to brave://apps/ you can see that inside brave the web-app is indeed generated but a shortcut is not created.

The Chrome browser has the ability to add a web-app icon to the Gnome dock. I expected that Brave would work the same way.

For now, my workaround is opening brave://apps/ and launching the app from there but that is terrible workflow. I want a launchable web-app icon in my Gnome dock like Chrome browser gives me.

I have tried searching. No web-app is created. I don’t know how Chrome Browser creates web-app launchers in Linux, but for some reason this functionality has been removed in Brave Browser.

I can only imagine that Chrome generates a linux style .desktop file for each web-app and puts them in a hidden data folder in ~/.local maybe?

I’m not savvy with this kind of thing.

I found a possible work-around that may work but I have not tried it yet.
I am trying it now but it is very convoluted. An average user will not be able to do this. After creating the .desktop file you also need to move it to ~/.local/share/applications/ folder.
Please fix this issue for the Linux version.

Here is the workaround.

I still cannot get it to work. The .desktop file is generated wrong. It needs a lot of tweaking. It still does not run. It links to a profile that I deleted a long time ago and it also opens an instance of Brave that does not contain any of my created profiles. It is really weird. I feel like I am so close but just cannot get it to work.


I got the launcher actually launching the apps in the correct profile.
Here are the edits you need to make to the .desktop file:

FROM: Exec=/snap/brave/125/opt/ --profile-directory="Profile 1"
TO: Exec=/snap/bin/brave --profile-directory='Profile 1'

Notice that the exec directory has changed AND the double quotations in the profile directory have been changed to single quotations.

The app will launch but the icon directory needs to still be fixed.

Still working…

1 Like


I am frustrated because I have a feeling that there is a MUCH EASIER WAY that I cannot find. Until someone figures it out, you will need to link each icon MANUALLY as follows.

Here is an example of my ‘Icon=’ line in my .desktop file

Icon=/home/username/snap/brave/125/.config/BraveSoftware/Brave-Browser/Profile 1/Web Applications/Manifest Resources/gakplicejlpogogkmhcohnidacakppdg/Icons/512.png

For each individual app you will need to find it’s icon resource buried in the following folder

~/snap/brave/125/.config/BraveSoftware/Brave-Browser/<profile name>/Web Applications/Manifest Resources/<web app id>/Icons/ 

Enjoy a day of work creating a .desktop file for each app and linking to each icon indidivually.

1 Like

@boomerlife I was able to create a shortcut for a Web page using the Hamburger > More Tools > Create Shortcut, and it appears both on my desktop and in my system menu. I’m running Debian 10, which shouldn’t be too different from Ubuntu.

Maybe it has to do with me running the snap version of Brave?

I have now uninstalled the snap version of Brave which I had gotten from the Ubuntu Store.
I then installed Brave using the instructions from the Brave website itself and the problems is solved.

I am now able to install web-apps with zero issues on Ubuntu 21.04.
Installing the web-apps automatically adds them to my apps drawer and they open with their own icon on the dock.

Thank you all.


Apologies for the late reply – I was just going to ask if you had downloaded Brave via the official instructions or if you’d used a Snap package or some other method. Glad you figured this out and I’m glad the functionality is working as you expected it.