Hiding Brave Reward Icon

Description of the issue:
In nightly and Beta build, you guys change the setting to hide Brave reward icon from “Hide brave reward icon” to “Show Brave reward icon in address bar” (Reversed) which make me can’t hide it, when in Nightly and beta when I turn off Show Brave— and relaunch. It’s keep reseting (turned on permanently). So I need to use stable version because the setting still the old one. And it’s work perfectly to hide that icon.
How can this issue be reproduced?

  1. Go to setting
  2. Open appearance tabs
  3. Turn off “Show brave reward Icon in address bar” then relaunch your browser

Expected result:
The brave reward icon disappear.

Brave Version( check About Brave):
Brave - Nightly 1.37.26. Chromium 98.0.4758.87

Additional Information:
Device: Vivo Y30 (Vivo 2019)
Android 10

Oh yea, if you didn’t understand my words. Please tell me, I would love to define it. :slight_smile: