Help with Security Settings in Address Bar

Description of the issue: I recently noticed that the Brave search address bar does not display the appropriate security status for sites I visit (e.g., to the left of the URL it’s supposed to display lock=secure, exclamation=not secure, X=dangerous).

How can this issue be reproduced: After typing in the desired URL, a new/different symbol is displayed and when clicked on, three options are displayed (security setting, cookies and site data, site settings).

Expected result: I expect to easily see the lock icon when visiting a site to know it’s secure (without having to click on a new symbol to verify this).

Brave Version( check About Brave): 1.59.117

Additional Information: I restored my Brave settings but that didn’t make any difference. I also have searched Brave help content and community postings and can’t find anything that explains when or why this was changed, nor whether there’s a way to change this back. Appreciate any suggestions to help with this.

@Bmpls Brave has changed how this works. If you click the icon, you’ll see the old options, such as in the screenshot below:


Main thing is Brave now upgrades to HTTPS by default. You can also choose a lot of your priorities as well. For example:


Or the drop down options when you check from the global settings:


If you have it set in your settings to upgrade to HTTPS, especially if strict, then you should know it’s secure. Brave won’t open it otherwise or will at least give you a warning page first.

Thanks much for the quick reply. I had noticed that by clicking on the icon, I could see the old icons, but thought I had to do that everytime. Appreciate knowing Brave will upgrade to HTTPS by default. Thanks again for the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.