Javascript is blocked on all websites. Someone please help

Someone please help me. I’m sorry but I am just so desperate. Javascript is completely blocked on all websites, there isn’t any switch to enable it. I can’t view websites without having to tediously enable it for one website at a time, which is a pain in the ass. I really am not liking my first experience with brave.

1 Like

Maybe Java itself is the cause? java.com_blocked

Anyway Java is prone to exploits and for your own security this is a good thing :wink:

@mr.Natural Java and JavaScript is two different things. :slight_smile:

@Neil_McGuy first, make sure you don’t have “Script blocker” enabled globally. Go to Settings > Brave Shields Defaults section.


Hi: I’m having same problem as OP, with one additional wrinkle: the radio buttons that should allow me to toggle javascript on for single websites are grayed out (see attached image). This means that many websites I visit are permanently broken. Any thoughts? Thx!Screen Shot 2020-03-06 at 12.23.11 PM

@radionowhere did you checked if you have Scripts blocker enabled? :point_up:

Thx for the quick reply!

Yes, I did check. No, it’s not enabled.

1 Like

For me that just had his laptop broken and stuck with an iPad it’s horrible , no YouTube or other streaming platform, no adds to gain BAT . Some sites just won’t open but you’re cool not having the problem . I bet yours is set on dispite the script vulnerability

Same here , I don’t even see any progress in BAT gain , can’t open some site’s where stream or gif or just Java , jeez ! Please update this and finding help about it is even worse

Didn’t helped for me

Can you please open a new topic on the forum for your issue and ensure that you fill out the template in the editor so that we have all the necessary information about your situation? Thank you.

1 Like

And that’s strange @radionowhere. Unless you have script blocker enabled, JavaScript will not be blocked (and script blocker is disabled by default).

I would try to clear “Site settings” (Ctrl+Shift+Delete to open clear option) and see if it can help.

1 Like

So it’s on windows as well as iOS . Thank’s for acknowledging the info

Figured it out: it was a “disable script” setting in the Web Developer extension. Didn’t realize that setting was persistent through page loads. Thx for all your help!


Believe or not but my pad was hacked in addition that my windows pc is in a unstartable reboot state for weeks now; about the Java running problem seems resolved and thank you for your help. On the other hand , do the rewards even work on iOS ?
Kind regards