HBOMax - Main Content shows Gray Bar (Beginning Promo loads fine, Post-Show content loads fine)

Description of the issue:
How can this issue be reproduced?

  1. Load ANY video on HBO Max
  2. Video loads > HBO Promo Content Loads > ‘Previously on’ Content Loads > Main Episode/Movie Video Content is simply gray (Including the HBO Logo load), but Audio works (screenshot below)
  3. Post Episode/Movie ‘Next time on’ type content loads fine

Expected result:
Video content loads

Brave Version( check About Brave):

V1.38.111 (May 3, 2022)

  • Upgraded Chromium to 101.0.4951.54.

Additional Information:

Widevine is enabled

Working prior to main content

Not Working

Console log during the ‘Gray’ point where video is not showing.


Brave community and support folk - where u at?

@coolcats202 ,

Suggestion, use the site-specific Shields (Lion icon) panels

in order to determine the degree to which, you need to lower - SPECIFICALLY - one or more of the settings.

For example, you may find that, for a web page, you only have to lower the Trackers & ads blocked level to Standard.

Close the web page.

The following steps, assume that you normally wish to have / leave Brave Browser > Shields: UP

Including the Global Shields Settings:

Global_Shields_Settings

With Brave Browser running, in a New Window, go to brave://settings/clearBrowserData

Examine all the settings for all three tabs: Basic / Advanced / On exit

Be certain that those settings are what they should be, for your usage. In time, you will have tested those arrangments, and figured out what you need, there.

Be certain for two of the tabs – Advanced / On exit – to Disable:

  • Passwords and other sign-in data (IF you are using Brave Password Mgr.)

  • Site and Shields Settings (unless, before the following steps, you decide that you initially do need to clear “Site and Shields Settings”)

Recommended at: brave://settings/cookies

  • Disable: “Clear cookies and site data when you close all windows”

  • Do not use: “Sites that clear cookies when you close them” (better to clear those cookie sources, manually: brave://settings/clearBrowserData)

Quit Brave Browser. Wait a moment. Start Brave Browser.

IF you want to allow cookies for the website . . .

In a New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter https://[*.]hbomax.com:443 as the site . . . but do not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Allow javascript for the website . . .

Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter https://[*.]hbomax.com:443 as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Repeat those steps for:

https://[*.]warnermediacdn.com:443

In order to make further adjustments to Site [specific] settings

Go to: https://www.hbomax.com

Right-click on the padlock icon at the left end of the URL address field.

In the pop-down menu, notice the setting for javascript - it should already be Enabled, because of the steps mentioned herein.

In the pop-down menu, scroll to the bottom and select ‘Site settings’

A Brave Browser > New Window will open to

brave://settings/content/siteDetails?site=https%3A%2F%2Fwww.hbomax.com

where you will again see that javascript is Enabled.

And, you may adjust several other Site settings, such as Ads.

I believe my issue was a password change on the actual account so likely not Brave related at all!

I went through the steps and had no luck then found out the PW changed. I’ll find out the new one and try again then update this thread!