HBO Max suddenly doesn't play anymore even when it worked fine days ago

Description of the issue: when pressing play for tv shows on HBO Max its left on an infinite loading screen. But works just fine on other browsers, like chrome.
How can this issue be reproduced?

  1. Open brave
  2. Go to HBO Max and log into profile
  3. press play
  4. tries to play video is left on loading screen
  5. turns shields on/off with no difference
  6. tries to restart nothing happens

Expected result:
being able to stream video

Brave Version( check About Brave):
version 1.18.77

Additional Information:
I tried looking up if it was HBO’s fault but all that came up was clearing the cache, I tired that and it didn’t work. I have windows 10. Please fix this issue.


@Bri.F Just tested this. It’s working for me (I was able to play WW84). The latest update addressed this issue.

Ensure brave://settings/?search=widevine is enabled, and clear the site settings (and relogin).

I am now having this issue. It started with the last update.

Fix incoming into next Brave minor release (week or 2). Apologies for the issues.

I have build Version 1.19.88 Chromium: 88.0.4324.96 (Official Build) (64-bit) and am experiencing the same issue. Tried playing “The Little Things” and it would not go past the loading screen. Shields up and shields down made no difference. I’m running on Windows 10.

1 Like

I’m not encountering this myself. Everything seems to be running properly for me on Win10 with the latest update.

Out of curiosity, can you try streaming HBO Max content in a private browsing window and see if you get the same results?

I just re-test HBO, and seems to be playing nicely here in Brave release. Possibly disable/re-enable widevine in brave://settings/extensions ?

@Mattches I tried it in a private browsing window and got the same results, perpetual loading screen.

@fanboynz I tried this solution as well and it didn’t do anything.

1 Like

@issahim ,
Thank you for confirming. We’re looking into this presently.

1 Like

@issahim ,
Are you seeing same behavior after the recent update to version v1.19.90?

im still on v1.19.88

Can force an update on brave://settings/help

Can you please go to Menu --> About Brave and initiate and update as @fanboynz stated?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.