Hardware acceleration in a Linux VM

I’m being plagued by freezes since the release after 1.0.1. Brave doesn’t crash, but very frequently halts all of a sudden for a number of seconds. And I finally found the culprit: Hardware acceleration being switched off.

Another important info: This only happens when running Brave in a Linux VM (VirtualBox on a Windows host). Outside a VM Linux hosts run the latest Brave without problems.

Unfortunately this issue makes Brave unusable for me. Because:

  • When the hardware acceleration is switched off, I’m having frequent freezes.
  • When the hardware acceleration is switched on, sooner or later Virtualbox crashes and halts the Linux VM in its tracks. Causing file system corruptions in the VM.

Unfortunately I’m not allowed to run Linux directly. I’m obliged to use a Windows hypervisor instead.

Maybe an interesting hint is that Chromium does not freeze when the hardware acceleration is disabled. It is very workable that way. However, it does crash virtualbox too when acceleration is enabled. (That’s why I immediately disabled when installing Brave.)

To set up a testing environment:

  1. Install Virtualbox (6.1.2) on Windows 10 64bit.
  2. Create a VM for Mint 19.3, max display memory, use vmsvga video card, enable 3D acceleration
  3. Start the VM
  4. Install the latest .deb release of Brave
  5. Start Brave inside the VM

To cause freezes:

  1. Disable hardware acceleration
  2. Surf a bit around on the web. Freezes will happen very quickly.

To cause VirtualBox to crash:

  1. Enable hardware acceleration
  2. Surf around on the web
  3. Close and open Brave a few times. Sooner or later Windows reports an error and will close Virtualbox.

Unfortunately, I don’t see how to work around this issue. It’s freezing all the time or an occasional crash. Neither is workable for me. :frowning:

Host system info:

  • Windows 10
  • HP Elitebook
  • Virtualbox 6.1.2

VM system info:

  • Linux Mint 19.3, Cinnamon
  • amd64

Brave info:
Version 1.2.43 Chromium: 79.0.3945.130 (Official Build) (64-bit)

1 Like

The freezes happen for both 4.15 and 5.3 kernels.

Virtualbox also crashes when enabling hardware acceleration using older Linux kernels.

Interesting – I’ll have to spin up a VM and try to test this but I’m imagining that this has more to do with the VM’s virtual hardware settings. It sounds like you know exactly what you’re doing, but to confirm, are you allocating enough of the appropriate resources (video specifically) to the machine and, further, does the host machine have the resources to support it?

I am pretty certain the vm has wat it needs. I’ll fiddle with some settings and see what it gives.

The display settings:

  • Memory 128M (maximum virtualbox allows)
  • Controller VMSVGA (required for Linux guests)
  • 3D acceleration is enabled (allows the VM to do graphics acceleration, not just 3D)

Virtualbox VM crashes with Chromium/Chrome are nothing new. I know about this for some time now. That’s why I have the reflex to disable the hardware acceleration
in the browser from the start. So this issue has to be fixed in the upstream project I’m afraid.

The real issue is the freezes. It must be somewhere inside Brave code, because I’m running totally fine with the 1.0.1 release w/o hardware acceleration.
No lags, no freezes. For me it is totally acceptable to run this way for some time. But I value my privacy, so I’d really like to be up to date.

Chromium has no such freezes when it runs inside a VM w/o hardware acceleration. The release on my vm is “Version 79.0.3945.79 (Official Build) Built on Ubuntu
, running on LinuxMint 19.3 (64-bit)”.

The issue must have been introduced in the 1.1.20 release. Because that’s the first release the behavior appeared.

If you want me to run tests to narrow down the issue, I’ll gladly help.

Just to be complete about the configuration of the VM:

  • Guest additions are installed on the VM.
  • Virtualbox has the corresponding extension pack installed too.

Thank you for the information. I didn’t get a chance to try and duplicate your VM setup yesterday but I will be doing so today to see if I can see the freeze you’re encountering. Will let you know the results!

If you want I make a Virtualbox appliance file you just have to import. I’m going to make a separate vm anyway for testing the latest Brave release w/o crashing my work vm.

I confirm seeing lags too only on Brave version “V1.2.43” on Lubuntu (bionic) under VirtualBox version “6.1.2 r135662 (Qt5.6.3)” on Mac OS host.

Graphics controller set to VMSVGA with 64 MB video memory. When I tried enabling 3D acceleration, I could not get the guest to boot.

Guest additions: installed
Extension pack: installed

Just trying to capture that this is not a one off case.

Same problem. Brave is now unusable for me.

It looks like the issue is fixed with release

Version 1.3.115 Chromium: 80.0.3987.87 (Official Build) (64-bit)

I’ve been using it for a few hours now. Without hardware acceleration. The performance is good. So, for what I am concerned, the issue is fixed. Thank you Brave !!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.