Hardware acceleration enabled, but doesn't work

Description of the issue:

In my brave settings menu I have Hardware Acceleration enabled. I check my brave://flags, and at a glance, what I assume should be enabled, IS enabled.

I’m running it on Linux, via Snapcraft.

How can this issue be reproduced?

  1. Installed Brave on Linux via Snap Store
  2. Enable hardware accelleration in brave
  3. See output of brave://gpu

Expected result:

GPU Hardware acceleration enabled

Brave Version( check About Brave):

Version 1.35.101 Chromium: 98.0.4758.87 (Official Build) (64-bit)

Additional Information:

Other applications installed on my system that successfully uses hardware acceleration include, Blender3D and the Godot Game engine. Why not Brave?

Do you per chance have multiple GPUs (or CPU with integrated graphics) hooked up? If so, is Brave using the same one as Blender, Godot, etc.?

I was wondering the same thing :point_up:

Also I know you said other applications use it fine but I’m wondering if you see HWA working with other browsers specifically ( ideally one that uses Chromium as well)?

I have only one graphics card, so I only have the one GPU afaik.

Chrome

Version 98.0.4758.80 (Official Build) (64-bit)

Graphics Feature Status

  • Canvas: Hardware accelerated
  • Canvas out-of-process rasterization: Disabled
  • Direct Rendering Display Compositor: Disabled
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Disabled
  • OpenGL: Enabled
  • Rasterization: Software only. Hardware acceleration disabled
  • Raw Draw: Disabled
  • Skia Renderer: Enabled
  • Video Decode: Software only. Hardware acceleration disabled
  • Video Encode: Software only. Hardware acceleration disabled
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Firefox

Checked the about:config and seems to be enabled there also.

Laptops often have a dedicated graphics card in addition to CPU integrated graphics. Are you using a laptop per chance? Since you are running Blender and Godot, I doubt it but better safe than sorry, right :slight_smile:

good question tho, but no I don’t use on laptop. That said… I do know that my motherboard has an on-board Intel graphics card; But I’ve never had screens connected to that. I only use the Nvidia card (which has 2 screens connected).

Something else I’m not sure if it came across, but I’m using Brave installed via Snapcraft. So that means it’s got snap confinement, could there be some restrictions or rules that means it’s not using the graphics interface correctly?

Oh dear, I have very little experience with snap, so this question goes over my head, I’m afraid. I hope @Mattches can answer. Is your Chrome also installed via Snapcraft? Or any other chromium based browser for which we can compare HWA performance?

No, Chrome is installed via APT (Firefox also), Blender is installed via snap tho

Well, if this doesn’t just take the cake. I was fiddling around with the flags following this post, and now I get the same Feature Status from your original post, and I can’t seem to revert it:

Summary

Graphics Feature Status

  • Canvas: Software only, hardware acceleration unavailable
  • Canvas out-of-process rasterization: Disabled
  • Direct Rendering Display Compositor: Disabled
  • Compositing: Software only. Hardware acceleration disabled
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Disabled
  • OpenGL: Disabled
  • Rasterization: Software only. Hardware acceleration disabled
  • Raw Draw: Disabled
  • Skia Renderer: Enabled
  • Video Decode: Software only. Hardware acceleration disabled
  • Video Encode: Software only. Hardware acceleration disabled
  • Vulkan: Disabled
  • WebGL: Software only, hardware acceleration unavailable
  • WebGL2: Software only, hardware acceleration unavailable

Problems Detected

  • Gpu compositing has been disabled, either via blocklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
    Disabled Features: gpu_compositing

Except this is on a Windows 8.1 laptop with dedicated Nvidia GPU (Intel CPU w/ integrated graphics is also present but not used), so I guess we can rule out snap confinement.

Well, if this doesn’t just take the cake. I was fiddling around with the flags following this post, and now I get the same Feature Status from your original post, and I can’t seem to revert it

Ouch! I feel partially responsible now! :sweat_smile:

1 Like

@andrewebdev,
Can you tell me what distribution of Linux you’re using?

Please don’t! brave://flags/ has a big warning banner at the top, so I knew the risks :slight_smile: I can always do a clean install if necessary, and at least we learnt something: presumable Snapcraft isn’t the problem, and it may have something to do with the ANGLE back-end.

            .-/+oossssoo+/-.               andre@andre-office 
        `:+ssssssssssssssssss+:`           ------------------ 
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 20.04.3 LTS x86_64 
    .ossssssssssssssssssdMMMNysssso.       Host: Z68AP-D3 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 5.4.0-99-generic 
  +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 49 mins 
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 2686 (dpkg), 40 (snap) 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: zsh 5.8 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 1080x1920, 1920x1080 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: i3 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   Theme: Breeze [GTK2/3] 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Icons: breeze [GTK2/3] 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Terminal: gnome-terminal 
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    CPU: Intel i5-2500K (4) @ 3.700GHz 
  +sssssssssdmydMMMMMMMMddddyssssssss+     GPU: NVIDIA GeForce GTX 760 
   /ssssssssssshdmNNNNmyNMMMMhssssss/      Memory: 3284MiB / 15991MiB 
    .ossssssssssssssssssdMMMNysssso.
      -+sssssssssssssssssyyyssss+-                                 
        `:+ssssssssssssssssss+:`
            .-/+oossssoo+/-.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.