Hardware acceleration does not work on Linux

It doesn’t seem to matter if I am using whether it’d be Arch or Debain based, if I installed chromium or chromium based application or even electron application, it doesn’t use hardware acceleration, even though the setting is enabled in the browser.

The only way to get it to work is to enable some gpu related flags through chrome://flags

So how come this is the case? On Windows 10 (on the same PC), this is not an issue at all, so I am not too sure why this happens on Linux on any distro?

Not sure, how are you verifying this? I can check on a Linux system after.

If you are confident it’s a Chromium issue though, putting something into the Chromium tracker will be the best way to get it worked on as that’s the underlying Brave engine.

1 Like

It is because Chromium 95 broke VAAPI, there is no way to disable the Ozone platform in Chromium 95 which doesn’t work with VAAPI.

Check out my thread Video hardware decoding (VAAPI) no longer works on Linux after update - #4 by kmod

Issue is fixed for Chromium 96 and VAAPI is working for me again after today’s upgrade of Brave to 1.32.106 (based on Chromium 96)

2 Likes

It seems to be fine, it seems to have taken them years to resolve this lol.