Hardware accelerated GPU video decoding (VA-API) doesn't work with Chromium 90+

Description of the issue:
Hardware accelerated video decoding doesn’t work starting with Chromium 90 builds. It was working OK with Chromium 89 builds.

OS: Ubuntu 20.04

How can this issue be reproduced?

  1. Follow this guide to enable vaapi support.
  2. Open a Youtube video
  3. Open brave://media-internals/ page
    – Video decoder says “FFmpegVideoDecoder” which is not GPU decoding.

Expected result:
Video decoder should be “MojoVideoDecoder” or “VideoDecodeAccelerator”.

Brave Version( check About Brave):
Version 1.24.85 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Additional Information:
Brave Version 1.22.72 Chromium: 89.0.4389.128 >> WORKING
Brave Version 1.23.71 Chromium: 90.0.4430.72 >> NOT WORKING

3 Likes

Here, guy says he made it work with Chromium but not Brave.

can confirm this for Mint Cinnamon 20.1. Tried the above with Brave 1.25.68 Chromium: 91.0.4472.77 and same results.

1 Like

Can also confirm this is still an issue in Version 1.26.67 Chromium: 91.0.4472.114

In brave browser videos are not using hardware decoding (even though brave://gpu says it should be). With the same settings in chromium videos are correctly using hardware decoding.

1 Like

For anyone else running into this issue… I was able to get this working by installing ‘ubuntu-restricted-extras’. Media inspection now shows true for hardware acceleration.

1 Like

With Intel, vaapi works with below command parameter and flags.

/usr/bin/brave-browser-stable --enable-features=VaapiVideoDecoder

Below flags are enabled.
brave://flags/#ignore-gpu-blocklist
brave://flags/#enable-gpu-rasterization
brave://flags/#enable-zero-copy

Below flag is disabled.
brave://flags/#enable-vulkan

Brave Version 1.27.108 Chromium: 92.0.4515.107 (Official Build) (64-bit)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.