Google's Pagespeed Insights does not work

When trying to check the speed of a page on Pagespeed Insights, I get the message “Requests from referer are blocked”

I am unable to use the site with shields up or down.

Exact URL of the website in question:

**Did the issue present with default Shields settings? (yes/no)**yes

Does the site function as expected when Shields are turned off? No, surprisingly

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): Site breaks regardless of shields

Does the site work as expected when using Chrome? Works in Firefox, haven’t tested Chrome

Brave version (check About Brave): v1.2.42

I just tested with twitter.

Only worked when I enabled “Allow all cookies” in Shields

Hey, thank you for replying. I got it to work when I Allowed cookies in shields.

I haven’t experimented too deeply, but if that setting is not set before turning off shields, it doesn’t seem to work.

Default settings > Shields off = Page gives me that error message.
First allow all cookies> Shields off=I can use the speed checker.

Could something be wrong on my end or is there a possibility that when shields are turned off, the cookie setting doesn’t get changed as well?

What site are you testing it against?

Can confirm doesn’t work with sheilds up…

However with sheilds down, I got the following result…

Perhaps this is an OS specific issue as well? What OS are you using?


Ok, I got home and tried it again. I was testing my own site, but not trying to promote anything here, so I tried it with another site (ghacks)

Here is what I experienced:

Shields on (default): error message
Toggle shields off: Page reloads and goes into the speed test
Toggle shields off and go back to main page to manually do test again: error message.

I’m running Windows 10 64 bit 1903.

Thanks for the report, have issued a patch, just needs to be approved.


I appreciate the help as always, thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.