Adblock Detected on this site

Description of the issue: Adblock detected on this site, that’s annoying

Exact URL of the website in question: https://spigotunlocked.org/

Screenshot of the ad as it appears in Brave

Did the issue present with default Shields settings? (yes/no) yes

Does the site function as expected when Shields are turned off? yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): no

Does the site work as expected when using Chrome? im not using chrome

Brave version (check About Brave): 1.43.90

What it meant was if it worked when you open the same site in Chrome…

Try turning off shields. It worked for me. You can do this by Clicking on the
Brave’s Lion icon on the searchbar then you’ll get shields are up Toggle switch, toggle it to off and hopefully that will do it

im not using chrome i need adblock for this site

You can’t view if you use ad block. Turn shields off, that will do the trick. (This worked for me)


firefox + uBlockOrigin with no adblock detected but firefox slow

implemented a fix for the site, give it 24hrs for the update to roll out.

3 Likes