CenturyLink.com Speed Test Page Broken

Description of the issue:

The page is broken when Trackers & Ads shield is set to Aggressive.

Exact URL of the website in question:

https://www.centurylink.com/home/help/internet/internet-speed-test.html

Screenshot of the ad as it appears in Brave:

Did the issue present with default Shields settings? (yes/no)

No

Does the site function as expected when Shields are turned off?

Yes

Does the ad appear when using a Private window as well? (yes/no)

Yes

Brave version (check About Brave):

1.61.101

Looks like a chrome issue

1 Like

Thanks for looking at this. If it’s a Chrome issue, why does it work when I turn off Aggressive shields?

1 Like

Just refreshing it fixed it for me, so adjusting shields refreshed the page. I was able to replicate the same issue in Chrome

1 Like

Sounds good. Thanks for double checking.

I have issue when ever i visit my webtoon sites in south korea like newtoki.co the browser always give error and did not works for me but chrome browser not causing me any issue.

The issue is always page broken like as discussed in this threat.

What error message? Just loaded here: Is there a specific webpage showing the error?

On my side the browser shows errors sometimes the page is broken and some time it loads. I am using window 8.

Does disabling shields help?

Where can i do this step?

In the url bar, disabling each option in the shields.

Thank you so much i disabled the option now its working fine. At least now working according to my needs.

Which shield option fixed it?

Browsing history and cache option works fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.