Google Voice does not recognize microphone

Description of the issue:

When I try to use Google Voice on Brave, it does not recognize the microphone or allow me to make calls.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

1.) Go to
2.) Click to make a call or call back someone who called you.
3.) It will say at the right-hand side " Allow mic access. Click Allow to use your microphone here." However, there is way to enable the mic and no pop-up from Brave prompting that the mic be enabled.

Actual Result (gifs and screenshots are welcome!):

No notification pops up asking me to enable the mic when I try to initiate a call. I only see the message below.

I do have the mic enabled, however.

Expected result:

A notification should pop up asking me to enable the mic. When I try to use Google Voice on a private browser, that notification does show up and Google Voice works fine.

Reproduces how often:

Every time I try to use Google Voice. I’ve never been able to get it to work despite reinstalling Brave several times.

Operating System and Brave Version(See the About Brave page in the main menu):

Windows 10
Version 1.4.96 Chromium: 80.0.3987.132 (Official Build) (64-bit)

Additional Information:

I have the following extensions:

  • Loom
  • Lightshot Screenshot
  • YouTube Playback Speed Control
  • OneTab
  • Vocus
  • Streak
  • TextBlaze Snippets
  • Loom
  • Screencastify

Hi @pasta829, welcome to Communtiy!

If you go to:
does it say Microphone = Allow

Also, have you tired quitting Brave and reopening? Or using it with Shields down?

Thanks so much for responding!

Mic is on, yes.

And shields are off and I have tried quitting/reopening Brave as well as uninstalling and reinstalling.

Any other ideas?

When you’re on Google Voice,

Do you see a headphone icon near the top right?

If you click on the icon, can you set/test your microphone and speakers to the device you’re using.

Does clicking on test play audio for you?

Does your microphone pick up audio? e.g. in this photo you can see the wave next to the microphone (if not try changing the input source)

Hey, thanks so much for replying! I just made a Screencastify video of what happens when I try to do those things you mentioned:

(In short, no luck.) Take a look?

P.S. I didn’t show the full Google Voice window just so all my recent incoming calls aren’t visible. But the right-hand part is what’s relevant.

That was awesome, thank you for sharing the video.

There might be an issue with your current profiles settings and/or the extensions you have.

To further diagnose this can you try creating a new profile:

Once make a new profile and the new window opens, go straight to and log into your account.
Once you’re in, click on the headphones icon, do you get the allow microphone access prompt?

If you do - click Allow
And then do you see the speakers/microphone devices listed?

That works, yes! With a new profile Google Voice works fine. Good idea!

Do you think it might be the extensions that I’m using on my main profile that are interfering?

I have the following extensions:

  • Loom
  • Lightshot Screenshot
  • YouTube Playback Speed Control
  • OneTab
  • Vocus
  • Streak
  • TextBlaze Snippets
  • Loom
  • Screencastify
  • Snovio

It could be an extension.
Before we start on extensions. I’d like you to clear the data/reset permission for the site.

Click on the lock icon to the left of the URL.

Then once the settings tab opens - close the google voice tab.

Once the voice tab is closed, click on clear data and then reset permissions. Quit Brave entirely > reopen Brave (make sure you’re not in the new profile) > go back to google voice > repeat the steps you did in the new profile but for your main profile.

If that doesn’t get google voice to work then it’s prob the extensions. Your next steps would be to disable them all, testing google voice, and enabling the extensions 1 by 1 to see which one causes the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.