Google Slides/Drawings messed up with new Brave Update

Hey guys, after updating Brave Browser on my Mac to the latest version, (v 0.68.141) I have noticed many bugs and issues while using Google Slides ( and Drawings ( Google Docs and Sheets are not affected. I use these apps for school and have been using them with Brave for about a year without any issues. The most notable issues are that I cannot select the text or move the cursor when using text boxes, and the text writes over itself to look like this:

If you are running Brave version 0.68.141 on Mac and try to use text boxes in Google Slides or Drawings, then you will most likely encounter this issue. I am a loyal Brave user, but I will be unable to continue using the browser if I can’t find a fix for this issue. Any suggestions would be much appreciated, thanks!

Hi @Arrow,

Thanks for reporting your issue! Just tried to reproduce on my end but was unable to. We pushed a new update (0.68.142) about 2 hours ago. When you have a sec would you mind updating and seeing if your issue continues?

Thanks in advance.

Hi @steeven,
I just updated and am now running v 0.68.142, still having the same issue. Here’s a screenshot taken just now:

I can try updating my Mac’s software tonight and see if that does anything if you think that would be helpful. It is currently running macOS Mojave v 10.14.2

Also, just so you know, I am not having issues with this on Safari or Google Chrome. That’s what makes me think it’s an issue with Brave and not my computer.

@Arrow Open Brave Shields panel and allow all device fingerprint methods (You will see a drop down menu). I think this should work. If not then toggle all the Brave Shields off

Thank you @Ujas! I turned off device recognition blocking and that solved the problem.

1 Like