Korean font not displaying correctly on google docs/slides/sheet

Hi, I am on a M1 macbook running Sonoma 14.2.1. Since last week Brave browser is behaving strangely. when I try to type korean characters in google doc/slides/sheets it displays like left side. For comparison when I use chrome browser (right side) it displays fine.
I’ve tried resetting the browser through chrome://flags/#enable-npapi page.
But did not work.
Any idea why this is happening?
Screen shot of the character image. Left: Brave, Right: Chrome both on google doc