Google search results are stuck in mobile view on Desktop

Whenever I search for something using Google as my search engine on my desktop or laptop, the search results are shown in mobile view as opposed to the desktop view as expected. I’ve taken a look at the views on the browser and other mobile related issues (I’m a mobile web developer) and there is nothing that I can find. I do not have any extensions installed and cannot find a reason why this is happening.

Has anyone experienced this issue or found a solution to it?

How can this issue be reproduced?

  1. Use the omnibox to search in Brave using Google
  2. Press enter
  3. Note search results in mobile view

Expected result:

Search results should be shown in Desktop view

Brave Version( check About Brave):

Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (x86_64)

Additional Information:

1 Like

Do you maybe have this mode enabled in DevTools (F12)?

1 Like

I don’t have that mode enabled in DevTools

I came to suggest the same thing @JimB1 did. To confirm, do you only see Google searches appear this way or do other sites appear this way as well?

Additionally, if you try to search Google in a Private browsing window, do they also appear this way?

Only Google search results appear this way. When I switch over to DuckDuckGo or Brave Search as my search engine of choice they do not show the same way.

When in private they show this way as well. It makes me wonder if this is an issue with Chromium as Chrome users have encountered a similar bug in the past. However, it is strange that not many people aside from myself are encountering this bug with Brave.

Any other thoughts?

If you go to your brave://adblock page, do you see anything entered in the Custom filters text area at the bottom of the page?

There’s nothing at the bottom of the page there. Any other thoughts?

@3raxton,
Can you also test this behavior with a new profile? I’m also wondering if you have any extensions installed at this time?

I created a new profile and the issue doesn’t happen on that new profile. However, it doesn’t fix the problem I am experiencing. Currently, I do not have any extensions installed.

Another issue I’ve encountered from this is not being able to click any large CTA on a website. Aside from that, I’ve noticed nothing else

This is embarrassing; I had Javascript turned off in my browser. Turning it back on fixed the issue! Hope this helps others down the line.

2 Likes

@3raxton,
Phew – honestly glad to hear that was the issue and not something deeper. Glad you were able to figure that out. Please don’t hesitate to reach out again if you have any additional issues or concerns.