Google search dark mode turns light mode occasionally

** Google search mode turns light mode on occasionally:**

It happens randomly through searches:

Does the site function as expected when Shields are turned off? Yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): No

Does the site work as expected when using Chrome? Yes

Brave version (check About Brave):
Version 1.66.115
Also when I change my search engine to Brave it also keeps showcasing as dark mode.

2 Likes

I have the same issue and it is super annoying
I am currently on Version 1.66.118 Chromium: 125.0.6422.147

When I open a new tab after a reboot or a longer time not using the browser, the new tab will open to the light version of google search. just clicking on the + to get a new tab will open google search in dark mode, as it should be.

Brave must be doing something strange on this first load, so that google doesn’t see my saved preferences and loads the default light mode.

Do your region settings also reset?

Several threads about this already. Check here: https://community.brave.com/t/shields-are-causing-google-search-to-reset-display-language-theme-settings-randomly

For me it’s stopped happening randomly, it only happens on the first search after I first run/restart the browser.

Exactly the same behavior here,
As already suggested here in an other thread, deactivating Brave-Shield does not solve the problem.

Same issue here!

There is another post saying the same too,

Been like it a month or two and is still happening on all my Brave devices

Google is set to dark mode but goes light mode and I have to refresh to get dark mode back

Driving me crazy now