Brave and Google Recaptcha Problem

Noticed there is becoming a major problem with Google Recaptcha lately in Brave the past few days where it’s giving a loop of recaptches and tons of pages that don’t want to be submitted due errors like “Cannot verify Recaptcha” I tested out Firefox and the puzzles are much shorter or even get an automatic green checkmark and to the point while on Brave for some odd reason Google has tightened the algorithm on this browser to the max to give users the worst experience possible. Tried it without shields and no luck, cleared all cookies and cache and nothing while in Firefox everything gets solved on just one page and Brave tons of pages just to solve one puzzle and even on some pages with Invisible Recaptcha V3 forms are failing to even submit.

  • Version 1.42.97 Chromium: 104.0.5112.102 (Official Build) (64-bit)
  • Disabled Shields and all extensions
  • Cleared Cache and Cookies
  • Tried being Logged into Google Account and not logged in
  • Tried other browsers like Firefox and regular chrome and no problems
  • It’s all sites giving the hardest recaptchas possible with disappearing and reappearing images and pages and pages of puzzles just to solve. While opening the same page in Firefox for example I just have to solve one page and done. Something is up in Brave.

I don’t know what but something in Brave is throwing off Google Recaptcha through the roof and assigning very bad reputation scores and hard puzzles while others browsers like Firefox work smoothly. It’s getting to the point where after all these years of using Brave I will have to switch to Firefox because this is a captcha nightmare on this browser. Never had any problems all this time until last week or something and have no idea if an update was made that made recaptcha so hard to solve on Brave with tons of disappearing and pages of puzzles. Does not make any sense why on Brave you get pages of infinite puzzles and errors while on browsers like Firefox everything works smoothly. Based on the research I did I see in the past the Brave has had issues with this problem and might be coming back again.

I’ve been experiencing an issue that I think is related. Details follow. I am using win10.

Example site that I can never log into using Brave:

  1. Disable Block Scripts in Shields
  2. Enter login information
  3. Captcha displays error

I notice the disabled block scripts option has a 2 next to it like it is not loading 2 scripts. However, you cannot enable/disable block scripts at this point or you just go back to the login screen. Same error when try with shields disabled.

In my case, I also cannot login to this site using Firefox, Chrome, Edge, etc. I can login using Tor browser. For the example site, the breaking point varies by browser, for instance, I can’t even get a login page in Firefox. Overall, it appears that any chromium based browser doesn’t work for me when I try to login to this site.

I also experience your specific issue, and most the time those sites seem to have scripts that don’t load at the captcha screen even with block scripts disabled. These instances seem to force an endless loop. Clearing history/cache and opening/closing browser has worked sometimes but most often not. Very irritating to have to open a different browser when I encounter these sites.

Posting link to my related topic below. Since that post, I am unable to get past the captcha page no matter what I do. Haven’t retested in anything else except Firefox (still no login option at all). Tor browser still works.

FYI Broke Site: Upland

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.