Google Meet Share Screen Non-Functional

Tried sharing/presenting screen under Google Meet and Meet reported error. Unable. All shields were off.

Logged out and back on with Chrome and was fine. I do use the Linux version.

Craig

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

@craigk,
You may need to grant permissions to the site to use your camera/mic and/or record video before you’re able to screen share. Additionally, Fingerprinting protection may be blocking the site from reading your screen. Try keeping your Shields panel up, but change the Fingerprinting control to All Fingerprinting allowed and see if this helps.

All Fingerprinting allowed set. Still does not work.

@rainevi,
And you allowed any/all permissions asked of you (check the address bar for a camera icon)?
Can you test it with Shields down entirely?

Yes. Allowed camera and microphone. Shields are down. Private session so extensions should not be interfering.

@rainevi,
Does it behave this same way when not using a private session?

Yes.

By the way I’m on macOS.

@rainevi,
This may sound strange but can you check and ensure that Autoplay is not being blocked by the site?

I set Autoplay to Allow from Ask (default) for meet.google.com and it made no difference.

@rainevi,
Can you confirm in your OS System preferences that Brave has permissions to everything necessary, such a screen recording – you may need to allow Full disk access but I’m not entirely sure.

Try opening (in your OS) Finder, go to Security & Privacy --> Privacy

There’s no setting for screen sharing access there. I see Full Disk Access but Chrome does not have it either and screen sharing works there.

@rainevi,
Apologies – the permission would be for Screen recording (as opposed to “Screen sharing”):


(note that in this example mine is showing Brave Browser Dev – if you’re using the stable release it should just say Brave Browser).

If it’s not there (in the list of apps allowed to record your screen), can you try adding it and trying Google Meet again?

Looks like “Screen Recording” does not exist in my version of Mac. I’m on Mojave 10.14.6.

@craigk I had this same issue recently on windows. The issue was the hangouts components for screen sharing was turned off. As soon as i switched it on, worked like a charm! Hope this helps!

brave://settings/extensions -> Hangouts – Uses Hangouts component to enable screen sharing and other features in the browser.