Can't share screen on google meet sesion

The button doesn’t work, it goes dark grey and the share isn’t going on.
i tried on another browser and it function normally, the problem occurred after i installed bitdefender, and some admin settings was changed, i think…
if someone know what i need to do to be able to use the share screen funtion again please help me :smiley:

Operating System and Brave Version: windows 10; brave V1.36.112


Did you grant Brave the proper permissions to record your screen? If not the option likely won’t be available. You can check this by clicking the “lock” icon in the address bar while on and checking which permissions you’ve allowed.

Yes, everything is allowed, i think Bitdefender changed something in my computer settings but i don’t know what, that’s why i ask if someone know where should i give permissions for brave to access my screen?

Exactly the same behavior here. Clicking the screen sharing button does nothing, and it becomes greyed out. The popup to choose which monitor/window to share is missing. This works fine in Firefox.

Same issue here. I don’t know if this has anything to do with the docker desktop I installed a few days ago which enabled virtualization and WSL2. And it’s working on firefox.

For all of you experiencing this, I would test the screen sharing using a fresh browser profile (slightly more effective than testing with a Private window, although that information may also be helpful) and see if this behavior still occurs.

Testing on my end, I’m able to initiate screen sharing on both Windows 10 and macOS (Monterey) systems without any issue.

I tested screen share on a different profile (not a new one) and it is working on that profile. How can I fix the profile in which it is not working?

Thanks for testing. That’s a great question — can you try disabling any installed extensions and test to see if you get the same results?

Fixed, but not sure how: Screen sharing not working in Google meet - #4 by marcin.miodek

This has been driving me nuts. I fixed it like this:

  1. Click on lock in top left of browser while you’re in Google Meet.
  2. Click site settings
  3. Allow popups & redirects
  4. Allow motion sensors

Not sure what magic that did but it worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.