Google Maps slowness and CPU very high

Hello, since a few day, google maps is very slow and sometimes it freezes only under Brave. Both at home and at work. Also, I see the CPU raises to 70 - 90 % !!! (core i7 2.8 GHz). No problem if I use Edge of Chrome.
Thanks for your help.

1 Like

I believe it’s because Brave Shields is blocking a lot of Google’s crap. I also find Google Maps laggy, but personally it’s a sacrifice I’m willing to make for the good job of Brave Shields.

I agree with that. But Google maps is a very good tool as well as Brave is a very good browser.
However, this behavior is new (a few days). In addition, I have desabled Brave Shields for Google Maps since a long time.

You might try Shields = up but with Hardware Acceleration disabled.

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

I just saw a Github report regarding the issue.

Oh good! I thought it was my computer but other people are seeing the same issue. I have confirmed with a side by side test with the chrome browser that the issue is with Brave and not my internet connection.

I use google maps on a daily basis and I now have to resort to using the chrome browser when accessing google maps. It would be nice to have that functionality back in the Brave browser!


Could you check whether disabling Hardware Acceleration improves the performance, as suggested by @Mattches?

P.S I mentioned this thread in the Github report from my previous comment. If there is any additional information you could share, please do so.

I am the one who submitted the issue to github. My experiences match what the OP reports in this thread. Shields up/down makes no difference. Hardware acceleration makes no difference.

I don’t remember any updates to Brave in the last week or so. My guess is google maps has been changed in someway that is causing the problem. I’ll try bringing up the debug console to see if I can spot what elements are causing the lag.



Thank you for bringing up the issue on Github. Regarding updates - Brave 1.29.76 was released just a few days ago - 31st of August.

This problem started before then “I think”. Can’t be sure about that. I’m currently working from a hotel internet so I may have just assumed the problem was due to the network.

For what it’s worth, I profiled scroll-wheel zoom-out of google maps. Sadly I can’t upload it due to being a new user on this forum. Happy to email it if desired.

If you can PM it to me, I’ll be happy to post it here on your behalf.

You can also upload to a site like and paste the link into the thread directly. This will automatically embed he video/image you uploaded.

1 Like

It’s a text file. Perhaps someone can give me permission to upload?

I confirm that hardware acceleration makes no difference. It is not a network problem since I found the issue at home and far away at work on a professional fibered network.
I guess this issue will disappear as fast as it appeared…
I have posted also a topic on the Google Maps community forum.

Hardware acceleration is already turned off (and it produces a black video screen when streaming Netflix into Discord for our movie nights).

I got a minor speed improvement when I disabled shield access to google maps but it was still lagged out compared to google chrome. The only thing I can add, which has been mentioned is that the issue only started a few days ago.

Yes, it’s quite annoying, basically I don’t want to use Google Maps on Brave at at all anymore.
For me it’s the same, toggling shield or hardware acceleration doesn’t change much, works fine with edge browser.

EDIT: Actually I didn’t restart after ENABLING hardware acceleration. Works much better with that enabled, still is not normal given that have a fast CPU.

here is the answer from the google maps community :
brave://flags , unabale the “Accelerated 2D canvas” option.
I tried it, it is better but not satisfying. Still jerky mooving and 50 -60 % CPU (instead of 99%).
How about you ?

I have the same issue when using Google Maps.

FYI this problem is also reproducible on latest Chrome 93.0.4577.63 (Official Build) (64-bit) (cohort: 93_Win_63)

Enabling hardware acceleration solves the issue (both on Brave and Chrome).

The previous Chrome version didn’t have this problem.

Here is a temporary solution from the google maps community that works for me :
Try this URL (2D version of Maps) :
(link to the topic :à-95-testé-sur-2-pc-et-2-réseaux)

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.