Sluggish "street View" in Google Maps

This is very recent, because just weeks ago Street View was fluid, with 11 extensions active and 48 tabs open (almost all suspended, but anyway).
Now I’ve tried with a clean profile, no extensions, no Brave Shields, only google maps website open, and it’s sluggish either by rotating the “camera”, or specially by “travelling” through the streets, when in other browsers it runs smoothly.

There’s a way to make it work again as before, by going to brave://flags/, searching for Override software rendering list, enabling that property and restarting Brave. Then Street View plays fine again, but the thing is, I always had that flag deactivated and Street View worked normally before, besides that flag may be experimental, I don’t know how stable that is.
Also, in other chromium based browsers, Street View runs fine with that flag disabled.

Please check that.
Thanks

could you disable hardware acceleration

and have a nice day

Again, I have it disabled and always had, I just temporarily enabled it to see if would improve, and it did. But just weeks ago it didn’t need to have that flag active, it was always smooth.

Do you also notice sluggishness?

@Agent_Suave,
I don’t see any sluggishness on my end – can you try changing the Fingerprinting Protection setting in Shields to Allow all Fingerprinting? Note that you can change it back after if the test doesn’t work, but I’m curious if it will change performance.

Additionally, if that doesn’t make a difference, can you inspect the page and see if there are any errors that appear in the Console window?

Hi Mattches, I tried what you said with a private window with just the maps website, no extensions, and I’m afraid there’s no improvements, with or without fingerprinting disabled and zero warnings or errors on the console in both cases.

The “travelling” animation is very sluggish, so much so that I could make a printscreen during it at the first try. Not only that, but it appears distorted as you can see. Once the animation ends the image is corrected of course.

Another thing, I have "Use hardware acceleration when available" enabled, but going at brave://flags and searching for “acceleration”, the GPU option (hardware acceleration) is disabled. Shouldn’t they be the same?

See screenshots:

no they are not the flag is a customization for the hardware acceleration settings

@Agent_Suave,
These are two separate settings so no, those don’t have to match. That said, I would recommend you try turning HWA off in Settings and see if this helps with the performance on Google maps.

Disabling the HW option in settings/system didn’t work (I forgot to show it in the videos but trust me, it was disabled)
Anyway I did some videos for comparison:
The 1st video is from Brave, private window, all extensions disabled, no other tabs, and behold the stuttering.
The second video is from Vivaldi (same chromium engine), with extensions and some 30 tabs opened, and look at the smoothness… Brave was like this just a few weeks ago.

@Agent_Suave,
Thank you for the information – will bring this to the team and get back to you soon.

@Agent_Suave

I’m not aware of any issues regarding google maps, From a clean Brave Beta profile (with no extensions), does the performance improve?

Hello @fanboynz, I installed the Beta from that link you provided, clean in every aspect (it was literally just skipping the welcome intro and paste in the only open tab the same Gmaps link), and it’s the same low performance issue.
It doesn’t happen in Vivaldi or the new Edge browser, and it didn’t happen in Brave either just weeks ago.
Did Brave auto updated in that period?

I am going to install several portable Brave versions prior to this one, to see if some of them actually behave better.

Hello @Agent_Suave

could you disable hardware acceleration on that new beta installation

hope that help and have a nice day

Ok, I went to this website for portable versions of Brave. I started from a while back: I extracted Brave portable ver 1.12.112 (the current one is 1.15.75), and Street View was smooth as butter; then after removing that folder I extracted what I think was the previous version of Brave, 1.14.81, and again, silky smooth. Then after deleting that folder I extracted the most recent version they have there: 1.15.72 (EDITED), almost as recent as the current one (1.15.75), and… BINGO, it was sluggish.
I changed nothing in each installation, HW acceleration in settings system ON by default, and the acceleration in //flags option was OFF by default.

I believe that whatever changed between 1.14 (and previous) and 1.15 is what’s causing this issue. If you guys don’t see it maybe it’s because it’s noticeable only in certain hardware, or your PCs are way more powerful than mine.

Speaking of which, my hardware:
Intel Core i5 3470s @ 2.90GHz
8GB RAM dual channel
Motherboard ASrock H61M-HVS
Asus ATI Radeon HD 6750
SSD 120GB with 12GB free
HDD 1TB w/ 390GB free
Onboard audio

wow awesome work @Agent_Suave

that would really helpful the dev

thanks again and have a nice day :slight_smile:

1 Like

@justsomeone1
As you asked, I disabled HW accelaration in settings/system in the BETA version, with the same result: Sluggishness :frowning:

I just corrected a mistake: the most recent version present in that site which was also sluggish was the 1.15.72, not 1.14… sorry about that, wrong copy paste, lol

sorry for your issue and hope it get fixed soon