Google Docs Offline extension automatically disables after enabling

Description of the issue:
When performing certain functions in google docs, like copying and pasting without formatting or editing offline documents, it directs me to enable the Google Docs Offline extension via the Chrome web store. Each time I do this (by clicking the ‘Enable this item’ link on the same page: and reload google docs to implement it, I am presented again with the following notice on top of the google docs page: “The Google Docs Offline Chrome extension is missing or disabled. To edit offline, enable the extension. To disable offline editing, update your settings.” When I follow the link to enable the extension, I redirected to the same Chrome webstore page where I again must clink ‘Enable this item’, creating a never-ending cycle in which the Google Docs Offline features remain disabled.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Open Google Docs in the Brave browser.
  2. Copy text. Right click on the document, click ‘Copy and paste without formatting’
  3. Follow the link presented to install the Google Docs Offline extension.
  4. (If not installed, install the Google Docs Offline extension.)
  5. Click the "Enable this item’ link on top of the Chrome webstore tab.
  6. Return to Google Docs and follow the link on top of the tab to reload Google Docs to enable the extension.
  7. Try again to copy and paste without formatting as in step 2.

Actual Result (gifs and screenshots are welcome!):
Google Docs Offline extension remains disabled. Even toggling the ‘Offline’ switch in google docs settings leads to the same problem.

Expected result:
Google Docs offline editing remains enabled once installed.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS Venture 13.1
Brave v1.47.171

Additional Information:
I do not get this error on Google Chrome.

1 Like

Hello there @DNF please accept my apologies for this issue. Please try disabling hardware acceleration on your device, in order to disable Hardware Accelertation through the macOS terminal. Follow the instructions below:

Open the Terminal and enter this command: open -a "Brave" --args --disable-gpu

Let me know if that works.

Hello there,

Thanks for the fast response! It appears to work now so fingers crossed. I will keep you posted if it changes.


1 Like

Hi again @DNF glad to know that solved the issue at the moment, also you can try installing a fresh new version of the extension to see if that does not repeat.

If you have any other comments or concerns, please let me know.

Hello @Kevin_cc, unfortunately the same problem has come back again. I tried disabling hardware acceleration again but the issue (of having to reinstall the Google Docs extension) just keeps repeating. Do you have any tips for what else I could try?

1 Like

@DNF do you have any other extensions installed apart from the offline Docs extension? If that’s the case, please try disabling all of them and enabling only the Google docs extension to see if the issue persist.

To disable an extension do the following:

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Thanks for the fast response. In ‘Manage Extensions’ a warning on the Google Docs Offline extension indicated it was corrupt. I clicked “Repair” and it seems to be working fine now. I hope this persists!

1 Like

Good to know that! If the issue persist or have other concerns please let me know.


Same has been happening to me for at least a year now. I usually end up doing the “Repair” solution mentioned in the earlier post, which fixes it for a while, but it invariably ends up happening again (extension becomes corrupted at some point, no idea how).

Version 1.48.164 Chromium: 110.0.5481.100 (Official Build) (arm64)

1 Like

Hi there @speedyld8 does this same behavior repeat on other browsers or only fails when installed on Brave?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.