Google Analytics Dashboard Not Working

Description of the issue:
The Google analytics dashboard page does not work with Brave. There was a discussion about this in September of 2020 but the discussion is dead now. You can find it here

Exact URL of the website in question:

Did the issue present with Shields on

Does the site function as expected when Shields are turned off?

Does the site work as expected when using Chrome?
Yes. Verified on Chromium, but not chrome. Just vanilla Chromium.

Brave version (check About Brave):
1.50.121 Chromium: 112.0.5615.138 (Official Build) (arm64)

Edit: FIX
This was what was wrong. I had a custom /etc/hosts file that blocked ads. On this list was Removing this solved the issue. It was confusing because some browsers did not respect the /etc/hosts file and implemented some kind of internal browser DNS to get around it. These browsers included Thorium, Firefox, etc. Brave, Chrome, Vivaldi respected the /etc/hosts file and that is why wasn’t working

Working here, does it work in private window mode?

Nope, does not work on Private Window either where all extensions are disabled. I did try connecting to cellular data and checking but it still didn’t work. This is the arm64 (M1 Macbook Air) Build of Brave if that info is of any relevance. I’ll try more trouble shooting steps and keep here posted

Update: I downloaded google chrome to test this out. It did not work on there. I suspect something related to DNS or Proxy settings but changing them did not do much

Try changing DNS servers? do you have other filtering software?

I’ve tried changing DNS servers. I have tried Google DNS and Cloudflare and none of them work. I don’t have any other blocking software other than ublock origin. The website doesn’t load even with ublock origin off. The website loads on other browsers(firefox and safari) even with ublock origin on.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.