Google accounts signs out of Brave PC after closing the Browser

I had this same problem and JUST solved it (at least for me). Here was what fixed it for me:

  1. In Brave browser, navigate to the following in the URL bar: brave://settings/clearBrowserData

  2. Navigate to “On exit” tab.

  3. Toggle OFF (by unchecking box) “Cookies and other site data”

For me, this solved the problem. Hope this helps!

1 Like

I know you said you’re running Brave 1.31.91, but where are you getting the ‘Check Passwords’ feature and the syncing to a Google account from? I don’t believe these things are in a Brave release, so I’m assuming those are from an extension?

One way or another, I think something is deleting your cookie with your session authenticator in it. If you have another app on your PC which is ‘cleaning’ your browser data, or an extension is ‘managing’ that in some way, that could explain it.

Do you have the same issue with other browsers?

Nope, Brave Sync and password feature available for all platform on Brave.

“On exit” tab. options are off

No, unless I’m crazy, something isn’t right with your installation. Brave shouldn’t be syncing to a Google account at all; and the ‘Check Passwords’ feature I don’t believe is enabled in Brave either. Both of these things were shown in your original screenshot but it looks like that’s been removed.

Where did you get the installer from and how did you install it?

Do you have anything enabled (blue dot items) in brave://flags ?

Well i’m not sure, but here’s the screenshot

I used to install prereleases before and i know it is weird because @Mattches once said Google sync won’t be implemented to Brave in the future, or in the coming days at least. But I saw that Sync asked me to sign me in and it was normal not weird site redirection or anything. And so it was there and i signed out of it yet it shows to turn off. I think I have no choice but to uninstall and reinstall Brave.

You’ll also want to do the following (which I had already done before using the above solution:

  1. Navigate to brave://settings/cookies

  2. Toggle OFF “Clear cookies and site data when you close all windows”

Why there are two different places for this option is beyond me, but having either one toggled ON might be your problem. Let me know if this helps!

@JimB1 and @jeremykidd73 take a look at this.

This extension thingy by brave is broken it is mentioned in the github repo of brave. And yes, I guess this an integration.

Thanks for the added pics.

I also looked at the GitHub link, but I believe that is something else. I am fairly certain there is something wrong with your installation, as Brave has no business syncing anything to your Google account or using Google’s password check service. These are Chrome features, maybe from Chromium, that somehow sneaked into your Brave instance.

FYI @Mattches . Looks like he’s on PTO but hopefully he gets wind of this when he gets back, I can’t think of any explanation for this behavior.

Going back to my earlier post:

Note, I think the best thing will ultimately be for you to reinstall Brave. Or at minimum you could try a new profile. But if you have any interest in figuring out if there’s a way to rescue your existing one, the above questions will be important.

1 Like

I do understand that you want to help me and uninstalling and reinstalling will be great but I will lose this months BAT for Ads. That’s a prob.

That may be true. Not sure how to resolve that situation, maybe others can chime in.

But note the other suggestions as well. Not necessarily “solutions” but perhaps help us narrow down the source of the problem even further, with the possibility of fixing it in place.

Have you checked to see whether or not you get this same behavior when using a a new profile? I’m also wondering if any extensions you have installed may be at play here.

1 Like

I tried a new profile and didn’t find any problem with it. Thanks.

1 Like

Then I would wager that a particular extension is causing the issue here. Can you try returning to your main profile and disabling your extensions and test to see if this works? If it does, then you should be able to re-enable your extensions one at a time and narrow down which one is causing the problem.

@Mattches I have already checked this by not only disabling all extensions and restarting brave but also enabling only a single extension at a time and it wasn’t the problem, I am not sure why but as you may have seen

:arrow_double_up: this “Allow Google login for extensions” is causing this problem.
I found it out coincidentally when I was trying to turn of extensions, and then there was this Extension tab in the Settings menu and this built in extensions, I tried the new profile and there was no such problem, Google login problems and that weird syncing to my gmail is not a problem in the new profile. I thought that this was naturally syncing as Brave Sync but then logging out was not possible, it took me to the Google accounts page, then I looked into some similar issues in the Brave community and then came across a post where u said that Brave will not integrate syncing to google account, so I thought it was weird and so I posted this problem, in profile 1 this problem still exist but not in profile 2 so I switched off that in the Extension tab, I will switch to profile 2 after month’s ads pay out. Until then I still using the profile 1.

@JimB1 and @jeremykidd73 take a look at this.

This extension thingy by brave is broken it is mentioned in the github repo of brave. And yes, I guess this an integration.

That does seem to be the issue for you, however it is still specific to your profile it seems since you’re not getting the same behavior in a new profile and when I test this, I do not get this behavior on my end either.

Additionally, this issue you linked does not quite capture what you’re experiencing here. That issue is directly related to extensions installed in the browser that you login to using your Google account, whereas your issue has to do with being logged out of Google sites when that option is on.

To confirm, if you toggle that option “off” in your main profile, everything works just fine?

I’m also curious about the password check option you have – that shouldn’t be available in the browser. Can you share a screenshot of your brave://settings/security page? Do you know how you “synced” your Google profile into Brave?

@Mattches yup everything works fine if I toggle off that option in the main profile, except for the check password thingy. About third party extensions you can have look at the ones I use, they never gave this issue before.

Privacy Pass extension isn’t a password saver or checking extension, it is cloudflare challenge bypass extension. U can check it here.

About the brave://settings/security here’s the screenshot from my main profile (DiabloPC)

The password checky thingy on main profile.

Interestingly “Allow Google login for extensions” option is togled on in my 2nd profile and there seems to be no such issue.

The brave://settings/security is same in the 2nd profile.

Can you please tell me how you were able to “sync” your Google account?