Cloudflare Protection Won't Load Site on Desktop

This has been an issue on the desktop version for a few weeks now and the site is unusable even when the shields are down. I’m on 1.47.196 on Windows 7.

I see much issue here, I haven’t tested in older Brave builds to be sure. Using a VPN? Does it work in Chrome ?

I don’t use Chrome but on my phone, it loads alright after a few seconds. I have Brave on my phone too. Here’s a screenshot of what I see now:

This also started on Ducumon’s site too. I have tried everything like clearing cookies and dropping shields and the sites don’t load no matter what I do.

Testing needed here, so we know if its replicable or not

The strange thing is that these sites loaded fine a while ago and I have no idea why this would happen now. I tried loading them in a private window and no dice there. Shields down didn’t help either. I even tried using a different DNS service other than my ISP’s and nothing happens there.

EDIT: The sites are up and running again strangely as the verification checkmark popped up so it’s all good again for now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.