Fonts support in Brave interactive setup support


#1

I would immediately switch from Firefox under Fedora 29 if ONE small feature was not missing in the Brave setup.
I apologize if I just missed where it hides.
Brave is unusable without support of this path collected from Firefox

Preferences->General->Languages & Appearance->Fonts & Clors->Default Font->Advanced at FALL BACK TEXT ENCODING missing in Brave

This is NOT an issue of old vs new browsers but of LEGACY CONTENT THAT FAILS TO DECLARE ITS ENCODING.
Under Fedora 28 and 29 the Linux locale first variable LANG is by default set to utf-8 in my country, while sites www.qwant.com www.google.com www.brave.com gmail.com for example work only when LANG is central Europe,ISO. While almost all off the shelf Fedora-ware requiresapplications require UTF-8 It does not make any sense to expect the user to play with the locale feature wach time a different application page is needed.
The parameter does not appear at all in Brave seup contrarily to Firefox, so that it is seems to me impossible to use any text box upon launching Brave.

I would not have wasted the time needed to write this note if Brave was not the SPLENDID piece of work it is.


Arabic fonts-size too small relatively to Latin fonts
#2

Sorry for the late response.
I’m going to look into this for you. If you dont hear back over the weekend please bump this post to remind me.

Also cc @sriram who may know something about this.


#3

Could you try visiting this link brave://flags/#enable-regional-locales-as-display-ui and change the dropdown selection from Default to Enabled and check if this fixes the issue?

In general font settings are different for Firefox. Certain advance features are available via flags on Chromium.

Let me know if this fixes the issue