Flash wont load, even after PPAPI reinstall from above, missing from Components list


Description of the issue:
flash, which loaded fine just a few days back, will not load at all now. i rely on being able to view swf-files. i could not even find any of the template permissions to forceful enabled flash. it seems to be broken. its even missing from the components list chrome://components/

How can this issue be reproduced?
visit any pages with flash-based content. the page itself loads, but the flash content does not appear. no visual “start flash” indicators appear.

try to click the “lock” symbol > site settings > flash > allow
doesnt do anything either. it seems as if flash wont install at all on brave anymore

the flash content only shows a warning: “this plugin is not supported” so the issue might be the plugin but i already tried to reinstall it from adobe

UPDATE: Following instructions on this post Flash not working - STILL?
i visited some sort of game site that had a different flash feature. It made the “run flash” pop up appear in brave at least. nothing happened after that, so i assumed it was still broken. so then i reinstalled flash again, with brave closed. after that, flash started loading again where i use it. so not sure what was wrong, but i installed flash twice (once with brave closed) and visited a game website and activated flash from there… after that it works. very, very troublesome but at least it worked for me

Expected result:
i would expect flash to load, and to be installed. neither seems to be the case currently

Brave Version( check About Brave):
Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit)

Additional Information:
windows 10 pro 1909/18363.752, laptop lenovo legion

@chad90b,
Thanks for reaching out. Let’s start over – can you tell me what sites specifically you’re trying to view Flash content on that aren’t working in Brave?