Flash not Showing in Components

I am trying to update Flash on Brave but when I go to brave://components, Adobe Flash doesn’t appear at all.

Hi @shack,

Welcome to community! This post may shed some light - https://support.brave.com/hc/en-us/articles/360018163151-How-do-I-manage-Flash-audio-video-

Hey. Again, Adobe Flash Player does not show up in brave://components for me to be able to update

So is anyone gonna help?

Hi @shack,

If a website isn’t working, you might need to change your settings to allow Flash.

  1. To the left of the web address, click Lock or Info .
  2. At the bottom, click Site Settings.
  3. In the new tab, to the right of “Flash,” click the Down arrow Allow.
  4. Go back to the site and reload the page.

Am I getting automated messages? Are you guys reading the comments? I already allowed Flash on the website but I cannot update Flash because it’s not in brave://components. How do I fix that? I already have Flash but it needs to be updated and need it to show up in brave://components

Just gonna hop in this thread since I’m having the same problem as @shack. Flash player isn’t showing up in components and I’ve tried everything in the link @steeven provided and nothing worked.

Hi Shack, what OS and Brave version are you running?

Hey @shack,

After some fiddling around I think I got a work around.

If you have Chrome go to “C:\Users[profile]\AppData\Local\Google\Chrome\User Data” and find the file PepperFlash and paste it into “C:\Users[profile]\AppData\Local\BraveSoftware\Brave-Browser\User Data”

It still doesn’t show up in components but it seems to get the damn thing to work. Playing a few games on newgrounds and I don’t seem to have any problems aside for a few games that I’m not even sure are running off flash, been a while since I visited the site.

Hopefully this helps.

  1. What site is telling you to update — can we get a link/screen shot?
  2. Flash may need to be run before it appears in brave://components
  3. Flash is run on a per site, per session basis and it may not need to update at all