Error: The Brave Rewards server is not responding

Can’t view brave rewards, there’s an error message in that window.

I have tried disconnecting and reconnecting my verified Uphold account.
I have tried turning rewards on and off.
Updated to the latest version.

Operating System: Windows 10 Pro
OS Build: 18363.1082
Brave Version: Version 1.14.84 Chromium: 85.0.4183.121 (Official Build) (64-bit)

can you restart your router and restart your device also then try again

hope that help and have a nice day :slight_smile:

Tried restarting the router and the device. Didn’t work

sorry @Clumsyknight
idk then maybe some server issue or something else
let me call @Mattches to offer help and have a nice day both of you

@Clumsyknight,
Before anything can you please go to Menu --> About Brave and ensure that the browser updates itself to the latest available version (should be v1.15.72 at this time)?

Yeah, it’s updated to the latest version



Still the same error

The error’s still there. Also, I am not seeing any ads these days.

@Clumsyknight,
Can you check and confirm for me that you see the same message in the Brave Rewards panel (the one that drops down from your address bar)?

Sorry for the late reply


This is what the rewards panel displays.
Though, I still have BAT in my Uphold wallet.

I had that problem too…And because I had an HDD every time I open Brave, my disk usage was 100%. I had not an Uphold walled. My solution was to reset the wallet on Brave. I don’t know if that delete also what do you have in Uphold. That happened because I get a BSOD while Brave was opened, and that make Brave to lose some data I think.

To follow this up, I have started getting ads, but the rewards page and rewards panel still remain the same.

I saw you have a verified wallet. Can you try reconnect your Uphold account @Clumsyknight?

Yes, I tried reconnecting to my Uphold wallet by two methods

  • after disabling then enabling rewards
  • after disconnecting uphold wallet
    Both didn’t work

    I still see this card. However, ads are working now.
    Also, even with this error, I still received the September payout.