Email Redirect not working on web.de and gmx.de

When you try to click a link in an email you get the error code 403.
Description of the issue:

Steps to Reproduce:

  1. Get an Email with a link in it
  2. click the link dont copy paste it
  3. you get errorcode 403

Result: https://imgur.com/a/JtA1Ykq

Expected result:

Reproduces how often: Everytime you click on a link on the websites web.de and gmx.de

Brave Version(about:brave): Version 0.59.34 Chromium: 72.0.3626.81 (Official Build) (64-bit)

Reproducible on current live release : Yes

The bug is no problem as long as the link isnt shortened so you can copy paste the link in the URL bar.

1 Like

Any Results? I have the same issue…

2 Likes

Same here. Solutions welcomed

@adrian.mueller, @Bobi, @proton1,
Apologies for the late reply. Before we jump into troubleshooting, @adrian.mueller – I’d like to confirm that everyone is using the most up-to-date release (v0.62.50 at the time of writing this) to make sure we’re all on the same page.

Additional questions (for everyone):

  • Can you tell me which email client you’re using?
  • @adrian.mueller mentions in his initial post:
  • Does this mean that clicking links to these websites specifically from within an email throws 403 error, or does any link opened from within an email throws 403?
  • What operating system are we using?
1 Like

Hello! Thanks for the reply @Mattches !

I am using www.web.de and am logged in to my account there. I get Youtube Emails and when I click them I get the 403.

I do Mint 19 and have tried the newest Brave beta as well as the updated Brave 0.62.5
(Version 0.62.50 Chromium: 73.0.3683.86 (Offizieller Build) (64-Bit))

I now realized, it works if I click the link, wait for the 403, click in the webTOyoutube-URL and hit enter again. I then get a web.de notice, I leave web.de and must confirm, and then get to the linked url.

So it works, if i enter the popped up link-url and hit enter again.

There is nothing in the settings I can do to improve this. I tried shutting all security for web.de of as well as other features that could effect this, imo.

Thanks again!

EDIT: Here how it looks:
1: clicking youtube links from within the email-provider gets this 403 error


It just says: “OOPS, there has been a mistake! Error 403”
2: clicking then in the URL hitting “enter” gets this webDE notice:

It says: “You now leave webDE. If you continue you get to an external website.”
3: I click “weiter” here (continue) and then the URL gets soluted and I get to the destination URL (here being youtube).

@proton1,
Thank your for the clarification – looks like I had it backwards!
We have a similar issue to yours with mail.com:


I’m wondering if these are related. Would you mind sharing the console output for the actions performed?

  1. Login to your email and before clicking the link, go to Menu --> More tools --> Developer tools --> [Console]
  2. Perform the above steps as you described
  3. Submit screenshot here (or copy/paste text)
1 Like

Thanks @Mattches! Right on!

Any link from the Email provider webDe shows 403.

  1. Log into the web.de account.
  2. Click any link inside an EMail. (The console does not display anything, at this point.)
  3. Click the URL and hit “enter”.
  4. Click the web.de prompt “Weiter” (being forwarded outside web.de)
  5. Destination URL is reached and the outcome at the console as follows:

This issue is not new, it persists several month prior this posting, may be half a year ago.

Since i realized It is just 2 clicks more, im glad this works. Having it fixed would be awesome, anyways!

Thanks so much! Love Brave!

I remember having this problem at least half a year ago, maybe a year.

Will this reach ppl who can solve the issue?

Regards

+1 from me.

Having the same issue on GMX (gmx.net / gmx.de) right now.
It might have to do with the fact that GMX adds:

https://deref-gmx.net/mail/client/[PossiblePrivateCode??]/dereferrer/?redirectUrl=https%3A%2F%2F

in front of any link we receive.

I enabled cookies and Java Script for both gmx.net and deref-gmx.net, I even disabled shields entirely on both URLs but it doesn’t help.

Clicking a link leads to this error message:
53

Oops, an error happened. Error-Code: 403

Refreshing the page does not help while manually selecting the address in the URL bar and hitting Enter again leads to the correct redirect info message:
45

You’re leaving the GMX service. If you continue, you’ll enter an external website.

Everything works fine from hereon out.

1 Like

NOTE: it doesn’t work even if shields are disabled for gmx.net and deref-gmx.net yet it does work correctly if global shield settings are set to allow all cookies. During the redirection process, however, I can’t find any other website involved that would require enabled cookies. Weird.

1 Like

I will push this again. Issue NOT solved. Thank you!

1 Like

Thank you for bumping this issue – sorry for the delay. No update on this yet but I just made some noise about it internally. Should hopefully have more information soon.
Thank you for your patience and all the provided data, everyone’s reporting/notes are very useful.

1 Like

Hello. I have the same problem, but on GMX.com
I use Windows 10
Everything is up to date.

2 Likes

I am in the US, and just installed Brave (version 64.77). I use GMX email as one of my main personal email accounts, and I have the same issue described in this thread. If I click on any link in any email in GMX I get “Oops, Something Went Wrong. Error code 403”. I tried the couple suggestions described here, but nothing fixes the problem. This error does not occur with any other browser I have been using, so is there something else I should try in Brave? Thanks is advance for any help.

As I explained above, if you go to global shield settings (brave://settings/?search=shields) and allow all cookies, then it works.
It’s a problem though as this will allow all cookies for all websites unless you block each website individually.

Thanks. That did work. However, as you have pointed out, you would not want to leave the global setting in the Allow All position. That would defeat the purpose of a browser like Brave. So, now it is going to be very inconvenient to have to change settings every time I want to log into GMX. Is anyone working on a fix for this?

Thanks again.

@ThePhoenix @BraveNew,
To confirm, with Global Shields at their defaults, if you’re logged in and on GMX, if you open the Shields panel and disable the Ads and trackers option (specifically – not Shields down), does GMX still throw the same error?

@Mattches I’m not using GMX often, so I hadn’t checked in a while. Based on the complaints by others I was assuming nothing had changed. I’m using different versions of Brave for different purposes. GMX I always visit with Brave Dev.
I just checked again after a long while to give you feedback and with Brave Dev it now seems like global shield settings don’t matter at all. It now works with global shields blocking absolutely everything and GMX-specific shields only allowing scripts and first-party cookies.
So I guess for everyone else it will be fixed with the upcoming main release?

Thanks for looking into it!

1 Like

@BraveNew thanks for that update this should put a smiles on some of the users facing this problem. to the brave team and community thank you

Yes. If I am in GMX and I just change settings, without Allowing Cookies Globally, the error comes up every time. Changing the Global Settings to allow cookies is the only fix I have found at this point.