Mail.com email links not opening

#1

Description of the issue
Clicking links withing emails on Mail.com does not work. An error code 403 with “Oops, something went wrong” occurs. It’s possible it has something to do with the way they wrap their links when they are external.

Exact URL of the website in question
https://deref-mail.com/mail/client/PhXsRJehFQo/dereferrer/?redirectUrl=http%3A%2F%2Fr20.rs6.net%2Ftn.jsp%3Ff%3D001JXEl8TJyv-m1OeqztHqGBanT06C4xzD54OoqQJSHO6ucV4VgjvIUYGWgyBy43qYqYUu9ax5E2tULPLZGAlWa0iTyj5T2kK-zqPey_BxgMH3EBNvymH6Pm6-vk2taBdCnmBjjlH7Vt2tBt_QesGIpzYp-ktA2NuCl%26c%3D6dXxmfYb0IT5YDv9dCnOki6-6Yv3V-QGcsYaYztYQBT1a78FryVLWA%3D%3D%26ch%3DcvNSdzyKLdtb9fNIAL3aWbuyEewV4vxYCe8bcy2N-f1oL58a5v789Q%3D%3D

Did the issue present with default Shields settings? [Default states are: Block: Ads/Trackers, 3rd Party Cookies, 3rd Party Fingerprinting Allow: Encrypt Connections enabled (HTTPS), Scripts] (yes/no)
Yes

Does the site function as expected when Shields are turned off? (yes/no)
No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no)
No. Not that I can tell, since it does not work with Shilds off.

Does the site function as expected when using Chrome? (yes/no)
Yes

What Brave version/Build are you using when you encounter the issue?(About Brave info)
Version 0.60.47 Chromium: 72.0.3626.119 (Official Build) (64-bit)

1 Like

#2

I am having this exact issue, in fact I even got this error when I tried to verify my email for my Brave community account creation - I had to open a Chrome browser to do it. I just switched from Chrome, but if I’m not even going to be able to check my email I may have to abandon ship! Is there a fix for this?

0 Likes

#3

@greenwillow, @TheLioness22
Sorry for the delayed response.
I have tested this on my end and can confirm that links opened from within mail.com emails are not opened and instead throw 403 error. Please allow me to further test and get information from the team to see if we can get this resolved.

In addition, I’d like to confirm that you’re both using the latest release, which (at the time of writing this) is v0.61.51

0 Likes

#4

Thank you for the response!
My version is: Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)

0 Likes

#5

I also have the exact same problem with throwing a 403 error with my mail.com account. It’s a real pain. I’ve tried deactivating shields enabling redirects, nothing has made any difference.
Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit)

0 Likes

#6

Since this topic will automatically close in 2 days with no resolution, I guess we’re just out of luck?

0 Likes

#7

@greenwillow,
I’m happy to keep this thread open should the system close it automatically. I have opened an issue regarding the mail.com error for the team to review:

However, it’s worth mentioning that this issue is not present in the Developer version of Brave. In Dev, links open without issue so there’s a good chance this already has a fix in place moving down the pipeline:

1 Like

closed #8

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes